diff main/database/src/configure.ac @ 11394:9aee227e296c octave-forge

Populated new database package with initial postgresql interface.
author i7tiol
date Wed, 16 Jan 2013 06:17:06 +0000
parents
children d261dc71e497
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/main/database/src/configure.ac	Wed Jan 16 06:17:06 2013 +0000
@@ -0,0 +1,27 @@
+#                                               -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.67])
+AC_INIT([postgresql], [0.1.0], [i7tiol@t-online.de])
+AC_CONFIG_SRCDIR([__pq_connect__.cc])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_CHECK_PROG(OCTAVE, octave, octave)
+AC_CHECK_PROG(MKOCTFILE, mkoctfile, mkoctfile)
+
+# Checks for libraries.
+AC_CHECK_LIB([pq], [PQconnectdb])
+
+# Checks for header files.
+AC_CHECK_HEADER([postgresql/libpq-fe.h], ,[exit 1])
+AC_CHECK_HEADER([postgresql/pg_config_manual.h], ,[exit 1])
+AC_CHECK_HEADER([postgresql/libpq/libpq-fs.h], ,[exit 1])
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT