diff configure.ac @ 31127:1077a1c277fb

build: Use caching for Fortran values in configure. * configure.ac: Rename ax_blas_integer_size to ax_cv_blas_integer_size. * octave_blas_f77_func.m4: Use AC_CACHE_CHECK macro for Fortran values. Rename values from "ax_blas_..." to "ax_cv_blas_..." to comply with requirement for "_cv_" in configure cache naming.
author Rik <rik@octave.org>
date Wed, 06 Jul 2022 22:03:13 -0700
parents cb03340f298f
children 1d819b308578
line wrap: on
line diff
--- a/configure.ac	Wed Jul 06 14:15:02 2022 -0700
+++ b/configure.ac	Wed Jul 06 22:03:13 2022 -0700
@@ -781,7 +781,7 @@
   AC_MSG_ERROR([BLAS and LAPACK libraries are required])
 fi
 
-case $ax_blas_integer_size in
+case $ax_cv_blas_integer_size in
   4)
     HAVE_64_BIT_BLAS=no
   ;;
@@ -794,8 +794,8 @@
 esac
 
 OCTAVE_CHECK_SIZEOF_FORTRAN_INTEGER
-if test $octave_cv_sizeof_fortran_integer -ne $ax_blas_integer_size; then
-  if test $ax_blas_integer_size -eq 8; then
+if test $octave_cv_sizeof_fortran_integer -ne $ax_cv_blas_integer_size; then
+  if test $ax_cv_blas_integer_size -eq 8; then
     case $F77 in
       *gfortran*)
         case $F77_INTEGER_8_FLAG in
@@ -825,8 +825,8 @@
   fi
   ## We intentionally don't attempt to fix things up if the default
   ## Fortran integer size is 8 but BLAS appears to use 4-byte integers.
-  if test $octave_cv_sizeof_fortran_integer -ne $ax_blas_integer_size; then
-    AC_MSG_ERROR([your Fortran compiler must have an option for setting the default integer size to be the same size as your BLAS library uses ($ax_blas_integer_size bytes).  See the file INSTALL for more information.])
+  if test $octave_cv_sizeof_fortran_integer -ne $ax_cv_blas_integer_size; then
+    AC_MSG_ERROR([your Fortran compiler must have an option for setting the default integer size to be the same size as your BLAS library uses ($ax_cv_blas_integer_size bytes).  See the file INSTALL for more information.])
   fi
 fi
 AC_SUBST(F77_INTEGER_8_FLAG)