diff configure.ac @ 19744:1687269e31e4

build: Generate Octave logo icons from SVG source (bug #37062) * acinclude.m4 (OCTAVE_PROG_ICOTOOL, OCTAVE_PROG_RSVG_CONVERT): New macros. * configure.ac: Use them. Set AMCOND_HAVE_ICON_TOOLS. * etc/icons/Makefile.am (BUILT_PNG_ICONS): Build PNG icons of varying sizes from SVG source. (octave-logo.ico) Build Windows icon containing a subset of PNG icons. * etc/icons/octave-logo.ico, etc/icons/octave-logo.png: Delete.
author Mike Miller <mtmiller@ieee.org>
date Wed, 18 Feb 2015 00:10:22 -0500
parents 08033d583435
children c1654224bc99
line wrap: on
line diff
--- a/configure.ac	Tue Feb 17 17:34:48 2015 -0800
+++ b/configure.ac	Wed Feb 18 00:10:22 2015 -0500
@@ -159,6 +159,12 @@
 OCTAVE_PROG_PAGER
 OCTAVE_PROG_PYTHON
 
+## Programs used to generate icons file formats.
+OCTAVE_PROG_ICOTOOL
+OCTAVE_PROG_RSVG_CONVERT
+AM_CONDITIONAL([AMCOND_HAVE_ICON_TOOLS],
+  [test -n "$ICOTOOL" && test -n "$RSVG_CONVERT"])
+
 ### Default terminal font for the GUI
 case $host_os in
   mingw* | msdosmsvc)