diff configure.ac @ 25391:26070f36f1e7

Provide octave configuration files for pkg-config (bug #48775) * libinterp/octinterp.in.pc, liboctave/octave.in.pc: templates for the octave and libinterp .pc files. * Makefile.am, libinterp/module.mk, liboctave/module.mk, configure.ac: integrate the new .pc files in the build system. Clean by distclean since they are created by the configure script.
author Carnë Draug <carandraug@octave.org>
date Sun, 04 Sep 2016 16:09:43 +0100
parents e0f63e77a715
children 2cf750f5cb7d
line wrap: on
line diff
--- a/configure.ac	Thu Aug 18 12:09:56 2016 +0100
+++ b/configure.ac	Sun Sep 04 16:09:43 2016 +0100
@@ -188,6 +188,10 @@
 ## Programs used in configuring Octave.
 dnl Find pkg-config executable (sets $PKG_CONFIG)
 PKG_PROG_PKG_CONFIG
+## And where we will install our own .pc files.
+PKG_INSTALLDIR
+AC_SUBST([liboctave_pkgconfigdir], [$pkgconfigdir])
+AC_SUBST([libinterp_pkgconfigdir], [$pkgconfigdir])
 
 ## Programs used in Makefiles.
 AC_PROG_AWK
@@ -3269,7 +3273,9 @@
   Makefile
   build-aux/check-subst-vars.sh:build-aux/check-subst-vars.in.sh
   doc/doxyhtml/Doxyfile
-  libgnu/Makefile])
+  libgnu/Makefile
+  liboctave/octave.pc:liboctave/octave.in.pc
+  libinterp/octinterp.pc:libinterp/octinterp.in.pc])
 
 dnl We use a .in.h file for oct-conf-post.h simply to copy it to the build tree
 dnl so that we don't have to add the -I${top_srcdir} to any CPPFLAGS variables.