diff configure.ac @ 29559:99e3912441ec stable

build: Make relocation of dependencies with Octave optional (bug #60413). * configure.ac: Add new option "--enable-relocate-all". * build-aux/subst-config-vals.in.sh, build-aux/subst-cross-config-vals.in.sh: Replace parts of flags that match the prefix only optionally. * src/mkoctfile.in.cc (replace_prefix): Only replace arts of flags that match the prefix only if configured to do so.
author Markus Mützel <markus.muetzel@gmx.de>
date Sat, 24 Apr 2021 19:17:16 +0200
parents f4cf798e6d8f
children 0f57f0f47216 fc282fdd1a42
line wrap: on
line diff
--- a/configure.ac	Tue Apr 20 16:20:10 2021 -0400
+++ b/configure.ac	Sat Apr 24 19:17:16 2021 +0200
@@ -2636,6 +2636,16 @@
 AM_CONDITIONAL([AMCOND_BUILD_QT_DOCS],
                [test $ENABLE_DOCS = yes && test $build_qt_gui = yes])
 
+OCTAVE_RELOCATE_ALL=no
+AC_ARG_ENABLE([relocate-all],
+  [AS_HELP_STRING([--enable-relocate-all],
+    [assume that all dependencies that are installed under the same prefix are relocated when Octave is relocated])],
+  [if test "$enableval" = yes; then OCTAVE_RELOCATE_ALL=yes; fi], [])
+AC_SUBST(OCTAVE_RELOCATE_ALL)
+if test $OCTAVE_RELOCATE_ALL = yes; then
+  AC_DEFINE(OCTAVE_REPLACE_PREFIX, 1, [Replace prefix in mkoctfile flags.])
+fi
+
 ### Determine whether Mercurial ID should be embedded in library binaries.
 
 ENABLE_HG_ID=yes