diff configure.ac @ 24623:f39ae754a7d8

configure: test that makeinfo supports the @sortas command * acinclude.m4 (OCTAVE_PROG_MAKEINFO): Test that makeinfo supports the @sortas command, print a warning and disable docs if it doesn't. This makes explicit the newest command required to build the manual, which depends on Texinfo 6.1 and newer. * configure.ac: Update disabling documentation warning messages.
author Mike Miller <mtmiller@octave.org>
date Fri, 19 Jan 2018 15:09:42 -0800
parents 6c3b7ca0cb90
children f0de21a6a426
line wrap: on
line diff
--- a/configure.ac	Fri Jan 19 13:25:24 2018 -0800
+++ b/configure.ac	Fri Jan 19 15:09:42 2018 -0800
@@ -2777,20 +2777,20 @@
   [AS_HELP_STRING([--disable-docs], [don't build documentation files])],
   [if test "$enableval" = no; then
      ENABLE_DOCS=no
-     warn_docs="building documentation disabled; make dist will fail"
+     warn_docs="building documentation disabled; make dist will fail."
      OCTAVE_CONFIGURE_WARNING([warn_docs])
    fi], [])
 if test $ENABLE_DOCS = yes; then
   if test $opengl_graphics = no || test -n "$warn_OSMesa"; then
     if test -n "$warn_gnuplot"; then
       ENABLE_DOCS=no
-      warn_docs_graphics="building documentation disabled because no suitable graphics toolkit is available; make dist will fail"
+      warn_docs_graphics="building documentation disabled because no suitable graphics toolkit is available; make dist will fail."
         OCTAVE_CONFIGURE_WARNING([warn_docs_graphics])
     fi
   fi
   if test -n "$warn_makeinfo"; then
     ENABLE_DOCS=no
-    warn_docs_makeinfo="building documentation disabled because makeinfo was not found; make dist will fail"
+    warn_docs_makeinfo="building documentation disabled because makeinfo was not found or does not support @sortas; make dist will fail."
     OCTAVE_CONFIGURE_WARNING([warn_docs_makeinfo])
   fi
 fi