diff configure.ac @ 25487:fbc270aeb55d stable

* interpreter.cc (intialize_xerbla_error_handler, xerbla_abort): New functions. (interpreter::interpreter): Call intialize_xerbla_error_handler. * configure.ac (AMCOND_BUILD_EXTERNAL_LIBXERBLA): New conditional. * libinterp/module.mk (%canon_reldir%_liboctinterp_la_LIBADD): Add libxerbla.la as an additional dependency if building libxerbla as an external library. * liboctave/external/blas-xtra/module.mk: Update. Allow building a separate library for xerbla. * xerbla.c: Rename from xerbla.f and implement in C. Allow programs to define a handler function to call. * f77-fcn.c (xstopx): Modernize.
author John W. Eaton <jwe@octave.org>
date Wed, 20 Jun 2018 15:16:05 -0400
parents cf84db75ab57
children 3b211e9ceab1 fe3a7b831014
line wrap: on
line diff
--- a/configure.ac	Tue Jun 19 09:05:48 2018 -0400
+++ b/configure.ac	Wed Jun 20 15:16:05 2018 -0400
@@ -1110,6 +1110,16 @@
   AC_SUBST(F77_FLOAT_STORE_FLAG)
 ])
 
+BUILD_EXTERNAL_LIBXERBLA=
+case $host_os in
+  msdosmsvc | mingw*)
+    BUILD_EXTERNAL_LIBXERBLA=ues
+  ;;
+esac
+
+AM_CONDITIONAL([AMCOND_BUILD_EXTERNAL_LIBXERBLA],
+  [test -n "$BUILD_EXTERNAL_LIBXERBLA"])
+
 ### Dynamic linking is now enabled only if we are building shared
 ### libs and some API for dynamic linking has been detected.