diff configure.ac @ 3710:1220a9158bc1

make building 64-bit Windows binaries independent from enabling 64-bit indexing in Octave
author John W. Eaton <jwe@octave.org>
date Sun, 07 Sep 2014 06:42:40 -0400
parents 902562ce85fc
children 89d99c28a6a1
line wrap: on
line diff
--- a/configure.ac	Thu Sep 04 16:30:14 2014 -0400
+++ b/configure.ac	Sun Sep 07 06:42:40 2014 -0400
@@ -53,14 +53,25 @@
 esac
 AC_SUBST(SHELL)
 
-### If possible, use a 64-bit integer type for array dimensions and indexing.
+ENABLE_WINDOWS_64=no
+AC_ARG_ENABLE(windows-64,
+  [AS_HELP_STRING([--enable-windows-64],
+    [build a Windows 64 cross compiler; resulting build will work only on 64-bit Windows systems])],
+  [if test "$enableval" = yes; then ENABLE_WINDOWS_64=yes; fi], [])
 
 ENABLE_64=no
 AC_ARG_ENABLE(64,
   [AS_HELP_STRING([--enable-64],
     [(EXPERIMENTAL) use 64-bit integers for array dimensions and indexing])],
   [if test "$enableval" = yes; then ENABLE_64=yes; fi], [])
+
+if test "$ENABLE_64" = yes && test "$ENABLE_WINDOWS_64" = no; then
+  AC_MSG_WARN([--enable-64 implies --enable-windows-64])
+  ENABLE_WINDOWS_64=yes
+fi
+
 AC_SUBST(ENABLE_64)
+AC_SUBST(ENABLE_WINDOWS_64)
 
 BUILD_SHARED=yes
 AC_ARG_ENABLE(shared,