diff configure.ac @ 3887:768c5d4c5b4e

new configure option: --enable-qhull-no-strict-aliasing-flag
author John W. Eaton <jwe@octave.org>
date Fri, 10 Apr 2015 13:50:50 -0400
parents 58935b4de51f
children 2db17a8585e6
line wrap: on
line diff
--- a/configure.ac	Fri Apr 10 12:11:50 2015 -0400
+++ b/configure.ac	Fri Apr 10 13:50:50 2015 -0400
@@ -157,6 +157,15 @@
   [if test "$enableval" = no; then ENABLE_OPENBLAS=no; fi], [])
 AC_SUBST(ENABLE_OPENBLAS)
 
+ENABLE_QHULL_NO_STRICT_ALIASING_FLAG=no
+AC_ARG_ENABLE([qhull-no-strict-aliasing-flag],
+  [AS_HELP_STRING([--enable-qhull-no-strict-aliasing-flag],
+    [Compile Qhull with -fno-strict-aliasing flag])],
+  [if test "$enableval" = yes; then
+     ENABLE_QHULL_NO_STRICT_ALIASING_FLAG=yes;
+   fi], [])
+AC_SUBST(ENABLE_QHULL_NO_STRICT_ALIASING_FLAG)
+
 ENABLE_OCTAVE=stable
 AC_ARG_ENABLE([octave],
   [AS_HELP_STRING([--enable-octave=stable],