diff configure.ac @ 4748:a6b4355efbd6

new organization for release, stable, and default versions of Octave * release-octave-1-gnulib.patch, release-octave-1-qt.patch, release-octave.mk: Copied from stable-*. * release-octave.mk: Explain purpose of file in comment. Update package name. * stable-octave-1-qt.patch: Delete. * stable-octave.mk, default-octave.mk: Explain purpose of file in comment. Use invalid URL for sources. Set version to 4.4.0+ to distinguish from the octave-release package. * dist-files.mk: Update. * configure.ac: Accept --enable-octave=release option and make it the default. * index.html: Include a release-octave package in the list.
author John W. Eaton <jwe@octave.org>
date Thu, 28 Jun 2018 13:39:45 -0400
parents 9942a9c37ffe
children 202fa20cf559
line wrap: on
line diff
--- a/configure.ac	Thu Jun 28 09:12:42 2018 -0400
+++ b/configure.ac	Thu Jun 28 13:39:45 2018 -0400
@@ -269,12 +269,13 @@
 
 AC_ARG_ENABLE([octave],
   [AS_HELP_STRING([--enable-octave=stable],
-    [Enable a specific build of Octave (stable, default)])],
+    [Enable a specific build of Octave (release, stable, default)])],
   [case $enableval in
+     release) ENABLE_OCTAVE="release-" ;;
      stable) ENABLE_OCTAVE="stable-" ;;
      default) ENABLE_OCTAVE="default-" ;;
      *) AC_MSG_ERROR([bad value "$enableval" for --enable-octave]) ;;
-   esac], [ENABLE_OCTAVE="stable-"])
+   esac], [ENABLE_OCTAVE="release-"])
 AC_SUBST(ENABLE_OCTAVE)
 
 AC_ARG_ENABLE([binary-packages],