diff configure.ac @ 3044:eb1a22446662

substitute SHELL
author John W. Eaton <jwe@octave.org>
date Wed, 12 Jun 2013 14:09:28 -0400
parents cbfe5d38ff2c
children cbdf4575016d
line wrap: on
line diff
--- a/configure.ac	Wed Jun 12 13:50:50 2013 -0400
+++ b/configure.ac	Wed Jun 12 14:09:28 2013 -0400
@@ -37,10 +37,10 @@
 ### ensure /bin/sh is the default shell so this can be safely ignored by
 ### almost everyone.  However, when building for Android, for example,
 ### this will need to be set.
-SHELL_PATH=/bin/sh
+SHELL=bash
 AC_ARG_WITH([shell],
   [AS_HELP_STRING([--with-shell=SHELL],
-    [use SHELL as the shell interpreter (default: /bin/sh)])])
+    [use SHELL as the shell interpreter (default: bash)])])
 case $with_shell in
   no)
     AC_MSG_ERROR([A shell interpreter is required])
@@ -48,11 +48,10 @@
   yes | "")
   ;;
   *)
-    SHELL_PATH=$with_shell
+    SHELL=$with_shell
   ;;
 esac
-AC_DEFINE_UNQUOTED([SHELL_PATH], ["$SHELL_PATH"],
-  [Define this to be the path to the shell command interpreter.])
+AC_SUBST(SHELL)
 
 ### If possible, use a 64-bit integer type for array dimensions and indexing.