diff configure.ac @ 19841:07b970d6cdfe

Only install config.log in $octetc if user requested (bug #43087) * configure.ac: Add a --enable-install-build-logs configure option. Set AMCOND_INSTALL_BUILD_LOGS. * Makefile.am (octetc_DATA): Use AMCOND_INSTALL_BUILD_LOGS to include config.log in the list conditionally.
author Mike Miller <mtmiller@ieee.org>
date Mon, 23 Feb 2015 23:28:37 -0500
parents 4006a7377a19
children e8ccfc5d892b
line wrap: on
line diff
--- a/configure.ac	Mon Feb 23 23:05:30 2015 -0500
+++ b/configure.ac	Mon Feb 23 23:28:37 2015 -0500
@@ -2965,6 +2965,15 @@
 AC_SUBST(QT_LDFLAGS)
 AC_SUBST(QT_LIBS)
 
+### Decide whether or not to install build logs with Octave.
+
+install_build_logs=no
+AC_ARG_ENABLE([install-build-logs],
+  [AS_HELP_STRING([--enable-install-build-logs],
+    [install build logs (e.g. config.log) with Octave])],
+  [if test "$enableval" = yes; then install_build_logs=yes; fi])
+AM_CONDITIONAL([AMCOND_INSTALL_BUILD_LOGS], [test $install_build_logs = yes])
+
 CFLAGS="$original_octave_configure_CFLAGS"
 CXXFLAGS="$original_octave_configure_CXXFLAGS"