diff configure.ac @ 19355:22289e6e316e

build: Remove unused TEXINFO_LIBNAME definitions from Makefiles. * build-aux/common.mk: Remove substitution of makefile TEXINFO_LIBNAME variables with autoconf variables of the same name. * configure.ac: Remove TEXINFO_QHULL, TEXINFO_HDF5, TEXINFO_GLPK definitions. * m4/acinclude.m4: Remove declaration of TEXINFO_LIBNAME in OCTAVE_CHECK_LIB macro.
author Rik <rik@octave.org>
date Tue, 25 Nov 2014 08:36:46 -0800
parents dbde327460be
children 2218dd129a6b
line wrap: on
line diff
--- a/configure.ac	Tue Nov 25 16:15:01 2014 +0100
+++ b/configure.ac	Tue Nov 25 08:36:46 2014 -0800
@@ -708,8 +708,7 @@
   [warn_qhull=
   OCTAVE_CHECK_QHULL_VERSION
   OCTAVE_CHECK_LIB_QHULL_OK(
-    [TEXINFO_QHULL="@set HAVE_QHULL"
-    AC_DEFINE(HAVE_QHULL, 1, [Define to 1 if Qhull is available.])],
+    [AC_DEFINE(HAVE_QHULL, 1, [Define to 1 if Qhull is available.])],
     [warn_qhull="Qhull library found, but does not seem to work properly.  This will result in loss of functionality of some geometry functions.  Please try recompiling the library with -fno-strict-aliasing."])])
 
 ### Check for PCRE regex library.
@@ -891,7 +890,6 @@
   [hdf5.h], [H5Gget_num_objs], [], [],
   [warn_hdf5=
    OCTAVE_CHECK_HDF5_HAS_VER_16_API
-   TEXINFO_HDF5="@set HAVE_HDF5"
    AC_DEFINE(HAVE_HDF5, 1,
      [Define to 1 if HDF5 is available and newer than version 1.6.])
    if test $have_msvc = yes; then
@@ -958,8 +956,7 @@
   [glpk/glpk.h glpk.h], [glp_simplex], [], [],
   [warn_glpk=
    OCTAVE_CHECK_LIB_GLPK_OK(
-    [TEXINFO_GLPK="@set HAVE_GLPK"
-    AC_DEFINE(HAVE_GLPK, 1, [Define to 1 if GLPK is available.])],
+    [AC_DEFINE(HAVE_GLPK, 1, [Define to 1 if GLPK is available.])],
     [warn_glpk="GLPK library found, but does not seem to work properly -- disabling glpk function"])])
 LIBS="$save_LIBS"
 CPPFLAGS="$save_CPPFLAGS"