diff Makefile.am @ 18328:c3f3fa5a5db5

build: Add rule to check with jit compiler enabled * configure.ac: Add conditional for HAVE_LLVM * test/Makefile.am: Add check-jit target * Makefile.am: Add check-jit target
author Stefan Mahr <dac922@gmx.de>
date Mon, 04 Nov 2013 00:04:55 +0100
parents 437df9a60536
children 8473198fd005
line wrap: on
line diff
--- a/Makefile.am	Mon Jan 06 14:00:43 2014 +0100
+++ b/Makefile.am	Mon Nov 04 00:04:55 2013 +0100
@@ -129,6 +129,11 @@
 check: all
 	$(MAKE) -C test check
 
+if AMCOND_HAVE_LLVM
+check-jit: all
+	$(MAKE) -C test check-jit
+endif
+
 run-octave: run-octave.in Makefile
 	@$(do_subst_script_vals)
 	chmod a+rx "$@"