diff Makefile.am @ 17102:c48625614ea6 stable

Properly incorporate Doxygen into the build system * Doxyfile.in: Rename from Doxyfile and move to doc/doxyhtml directory. Templatise properly with autoconf macros. Configuration tweaks: expand DEFUN macros, show namespaces, document the GUI sources, don't strip Doxygen comments from the source, allow dot to create larger graphs. Also add a a tagline and the Octave logo. * doc/doxyhtml/README: New file, grafted from the dev branch. * doc/doxyhtml/Makefile.am: New file, handles doxyhtml target. * Makefile.am: Add doxyhtml target. * configure.ac: Add doxyhtml files to AC_CONFIG_FILES
author Jordi Gutiérrez Hermoso <jordigh@octave.org>
date Sun, 28 Jul 2013 01:18:48 -0400
parents 72c96de7a403
children 054905bfc306 eff3d78367f0
line wrap: on
line diff
--- a/Makefile.am	Wed May 01 14:41:50 2013 -0400
+++ b/Makefile.am	Sun Jul 28 01:18:48 2013 -0400
@@ -128,6 +128,10 @@
 	mv $@.t $@
 .PHONY: ChangeLog
 
+doxyhtml:
+	$(MAKE) -C doc/doxyhtml
+.PHONY: doxyhtml
+
 octetc_DATA = NEWS
 
 DIRS_TO_MAKE = \