diff Makefile.am @ 14432:e053d1622f4e

build: Don't build DOCSTRINGS files when --disable-docs specified. * Makefile.am, scripts/Makefile.am, src/Makefile.am: Use AMCOND blocks to disable unnecessary documentation building when --disable-docs specified.
author Rik <octave@nomad.inbox5.com>
date Sun, 04 Mar 2012 14:42:19 -0800
parents 72c96de7a403
children af953acc055d
line wrap: on
line diff
--- a/Makefile.am	Sun Mar 04 13:57:42 2012 -0800
+++ b/Makefile.am	Sun Mar 04 14:42:19 2012 -0800
@@ -70,8 +70,7 @@
 # Subdirectories in which to run `make all'.
 SUBDIRS = libgnu libcruft liboctave src scripts @DOCDIR@ examples test
 
-if AMCOND_BUILD_DOCS
-else
+if ! AMCOND_BUILD_DOCS
 dist-hook:
 	echo "Documentation disabled.  Cannot package distribution!" ; exit 1;
 endif
@@ -119,8 +118,10 @@
 	  cp $< $@; \
 	fi
 
+if AMCOND_BUILD_DOCS
 AUTHORS BUGS INSTALL.OCTAVE:
 	$(MAKE) -C doc/interpreter ../../$@
+endif
 .PHONY: AUTHORS BUGS INSTALL.OCTAVE
 
 ChangeLog: