diff Makefile.am @ 16603:e5c0acc31640

install .gdbinit in test directory * build-aux/common.mk (gdbinit_install_rule): New macro. * Makefile.am (.gdbinit): Use it. * test/Makefile.am (all-local, .gdbinit): New targets.
author John W. Eaton <jwe@octave.org>
date Fri, 03 May 2013 00:29:07 -0400
parents 8b70f6118a5e
children 6a18ce4723f9
line wrap: on
line diff
--- a/Makefile.am	Fri May 03 00:27:55 2013 -0400
+++ b/Makefile.am	Fri May 03 00:29:07 2013 -0400
@@ -124,12 +124,7 @@
 	chmod a+rx "$@"
 
 .gdbinit: etc/gdbinit
-	@if [ -f .gdbinit ]; then \
-	  echo "refusing to overwrite .gdbinit with newer version from $<" 1>&2; \
-	else \
-	  echo "Installing .gdbinit from version at $<" ; \
-	  cp $< $@; \
-	fi
+	@$(gdbinit_install_rule)
 
 if AMCOND_BUILD_DOCS
 AUTHORS BUGS INSTALL.OCTAVE: