diff configure.ac @ 18854:0a66861d8069 gui-release

implementation of search in selection in gui editor (bbug #41196) * configure.ac: do the check OCTAVE_CHECK_FUNC_QSCI_FINDSELECTION * acinclude.m4 (OCTAVE_CHECK_FUNC_QSCI_FINDSELECTION): new function testing whether QsciScintilla::findFirstInSelection is available (added in 2.7) * find-dialog.cc (constructor): box for searching in selection enabled when function is available, connect signals when search has changed and when search selection is activated to the new related slots, initialize new flag for indicating an ongoing replace; (handle_search_text_changed): new slot reseting search result; (handle_sel_search_changed): new slot reseting search result; (handle_selection_changed): new slot enabling check box for search selection, nothing is done when the change was due to a replace operation; (find): revise calculation of cursor position for starting the search at end, add searching in selection if related check box is checked, use backward search when replacing all (do_replace): set flag for an active replace operation indicating that the selection is not changed by the user; (replace): switch to robust backward search, using new function do_replace; (replace_all): recover cursor position only when nor searching in selection, reset search result after operation, using new function do_replace * find-dialog.h: new flag for active replace operation, new slots
author Torsten <ttl@justmail.de>
date Sun, 22 Jun 2014 15:42:00 +0200
parents 2e68c34521e0
children 2b82d2f29a7b eea4f61960d4
line wrap: on
line diff
--- a/configure.ac	Thu Jun 19 15:51:05 2014 -0400
+++ b/configure.ac	Sun Jun 22 15:42:00 2014 +0200
@@ -2772,6 +2772,7 @@
     OCTAVE_CHECK_QFONT_MONOSPACE
     OCTAVE_CHECK_FUNC_SETPLACEHOLDERTEXT
     OCTAVE_CHECK_FUNC_QTABWIDGET_SETMOVABLE
+    OCTAVE_CHECK_FUNC_QSCI_FINDSELECTION
   fi
 
   if test $build_gui = yes; then