diff configure.ac @ 14776:0eb1b1eb2c76

Detect Carbon's CGDisplayBitsPerPixel during configure. Use it if present. Provide a replacement if it is not. * m4/acinclude.m4 (OCTAVE_CARBON_CGDISPLAYBITSPERPIXEL): New macro. * configure.ac: Use it. * display.cc: Define DisplayBitsPerPixel, and use it if CGDisplayBitsPerPixel is missing.
author Ben Abbott <bpabbott@mac.com>
date Sun, 17 Jun 2012 17:20:38 -0400
parents fa48fd0f160f
children 8e9f2cfa114d 466cb8673653
line wrap: on
line diff
--- a/configure.ac	Fri Jun 15 21:15:23 2012 -0400
+++ b/configure.ac	Sun Jun 17 17:20:38 2012 -0400
@@ -654,6 +654,8 @@
 OCTAVE_CXX_COMPLEX_SETTERS
 OCTAVE_CXX_COMPLEX_REFERENCE_ACCESSORS
 
+OCTAVE_CARBON_CGDISPLAYBITSPERPIXEL
+
 ### Check for the QHull library
 
 OCTAVE_CHECK_LIBRARY(qhull, QHull,