diff configure.in @ 518:2349d5721cd9

[project @ 1994-07-19 14:31:14 by jwe]
author jwe
date Tue, 19 Jul 1994 14:31:14 +0000
parents f264c1454c2b
children af19ffbbe91d
line wrap: on
line diff
--- a/configure.in	Wed Jul 13 14:38:02 1994 +0000
+++ b/configure.in	Tue Jul 19 14:31:14 1994 +0000
@@ -21,7 +21,7 @@
 dnl along with Octave; see the file COPYING.  If not, write to the Free
 dnl Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
 dnl
-AC_REVISION($Revision: 1.33 $)dnl
+AC_REVISION($Revision: 1.34 $)dnl
 AC_PREREQ(1.8)dnl
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -108,25 +108,35 @@
 DYNAMIC_LD_OBJ=
 DLD_DIR=
 LIBDLD=
-DLD_OBJECTS='$(DLD_OBJECTS)'
+LIBOCTDLD='../liboctdld.a'
 LD_STATIC_FLAG=
 if $use_dld; then
   DYNAMIC_LD_OBJ='dynamic-ld.o'
+  DLD_DIR=dld
+  LIBDLD='../libdld.a'
+  LIBOCTDLD= # don't link them in if doing dynamic linking
+  LD_STATIC_FLAG=-static
+  AC_DEFINE(WITH_DLD, 1)dnl
+fi
+if test -n "$DYNAMIC_LD_OBJ"; then
   AC_VERBOSE([setting DYNAMIC_LD_OBJ to $DYNAMIC_LD_OBJ])
-  DLD_DIR=dld
+fi
+if test -n "$DLD_DIR"; then
   AC_VERBOSE([setting DLD_DIR to $DLD_DIR])
-  LIBDLD='../libdld.a'
+fi
+if test -n "$LIBDLD"; then
   AC_VERBOSE([setting LIBDLD to $LIBDLD])
-  DLD_OBJECTS= : # don't link them in if doing dynamic linking
-  AC_VERBOSE([setting DLD_OBJECTS to $DLD_OBJECTS])
-  LD_STATIC_FLAG=-static
+fi
+if test -n "$LIBOCTDLD"; then
+  AC_VERBOSE([setting LIBOCTDLD to $LIBOCTDLD])
+fi
+if test -n "$LD_STATIC_FLAG"; then
   AC_VERBOSE([setting LD_STATIC_FLAG to $LD_STATIC_FLAG])
-  AC_DEFINE(WITH_DLD, 1)dnl
 fi
 AC_SUBST(DYNAMIC_LD_OBJ)dnl
 AC_SUBST(DLD_DIR)dnl
 AC_SUBST(LIBDLD)dnl
-AC_SUBST(DLD_OBJECTS)dnl
+AC_SUBST(LIBOCTDLD)dnl
 AC_SUBST(LD_STATIC_FLAG)dnl
 dnl
 dnl See if the optional nonlinear programming code is present.