diff configure.ac @ 19009:8d47ce2053f2 draft

Added safety checks to Array::xelem There's no reason to have a method which never checks invariants, ever. Added debugging checks to Array::xelem to help catch and debug out-of-bounds errors and reference overlap * configure.ac: Added configuration option for uniqueness-checking with xelem * jit-typeinfo.cc (octave_jit_paren_scalar): Call const Array::xelem rather than Array::xelem * Array-util.h, Array-util.cc (check_out_of_range): Extract common pattern to method (check_index): Methods to check index is in-bounds (compute_index): Added bool parameter check. does not check bounds when check is false and BOUNDS_CHECKING is off * Array.h, Array.cc (xelem): Use methods from Array-util.h to compute indices (is_unique): Check if this is the only reference to data * CmplxQR.cc, dbleQR.cc, fCmplxQR.cc, floatQR.cc (form): Move second assignment to after the call to xelem * lo-array-gripes.h, lo-array-gripes.cc (gripe_modifying_nonunique): Added error message for when non-const xelem is called on non-unique array
author David Spies <dnspies@gmail.com>
date Mon, 14 Jul 2014 13:07:59 -0600
parents 79d2dd9351cc
children
line wrap: on
line diff
--- a/configure.ac	Sat Jun 21 13:13:05 2014 -0600
+++ b/configure.ac	Mon Jul 14 13:07:59 2014 -0600
@@ -231,6 +231,19 @@
   AC_DEFINE(BOUNDS_CHECKING, 1, [Define to 1 to use internal bounds checking.])
 fi
 
+### Enable uniqueness-checking on array modifications
+### As with bounds-checking, this slows down some things a bit so it is turned
+### off by default
+
+UNIQUENESS_CHECKING=no
+AC_ARG_ENABLE([uniqueness-check],
+  [AS_HELP_STRING([--enable-uniqueness-check],
+    [enable uniqueness checking for direct array modification])],
+  [if test "$enableval" = yes; then UNIQUENESS_CHECKING=yes; fi], [])
+if test $UNIQUENESS_CHECKING = yes; then
+  AC_DEFINE(UNIQUENESS_CHECKING, 1, [Define to 1 to use internal uniqueness checking.])
+fi
+
 ### Use Octave's built-in memory allocator rather than straightforward malloc.
 ### Disabled by default.