diff configure.in @ 4382:f8373733d8f9

[project @ 2003-04-22 18:02:48 by jwe]
author jwe
date Tue, 22 Apr 2003 18:02:48 +0000
parents 7d48a8fba1d4
children a3020cb1fe0f
line wrap: on
line diff
--- a/configure.in	Tue Apr 22 16:57:29 2003 +0000
+++ b/configure.in	Tue Apr 22 18:02:48 2003 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.424 $)
+AC_REVISION($Revision: 1.425 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1389,14 +1389,16 @@
 #define OCTAVE_HAVE_SIG_JUMP
 #endif
 
+/* Always use new, since we sometimes allocate large chunks of memory
+   and that can cause trouble due to stack size limits.
 #if defined (HAVE_DYNAMIC_AUTO_ARRAYS)
 #define OCTAVE_LOCAL_BUFFER(T, buf, size) \
   T buf[size]
-#else
+#else */
 #define OCTAVE_LOCAL_BUFFER(T, buf, size) \
   std::auto_ptr<T> buf ## _auto_ptr (new T [size]); \
   T *buf = buf ## _auto_ptr.get ()
-#endif
+/* #endif */
 
 #if defined (__DECCXX)
 #define __USE_STD_IOSTREAM