diff doc/Makefile.am @ 9794:0d4613a736e9

convert build system to use automake and libtool
author John W. Eaton <jwe@octave.org>
date Tue, 10 Nov 2009 15:02:25 -0500
parents
children c657c056240d
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/doc/Makefile.am	Tue Nov 10 15:02:25 2009 -0500
@@ -0,0 +1,52 @@
+# Makefile for octave's doc/interpreter directory
+#
+# Copyright (C) 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
+#               2002, 2003, 2005, 2006, 2007, 2008, 2009 John W. Eaton
+#
+# This file is part of Octave.
+# 
+# Octave is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+# 
+# Octave is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+# for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with Octave; see the file COPYING.  If not, see
+# <http://www.gnu.org/licenses/>.
+
+TOPDIR = ..
+
+include ../common.mk
+
+EXTRA_DIST = \
+  Makefile.am \
+  ChangeLog \
+  conf.texi.in \
+  texinfo.tex \
+  texmf.cnf
+
+SUBDIRS = faq interpreter liboctave refcard
+
+all-local: conf.texi
+
+conf.texi: conf.texi.in $(TOPDIR)/common.mk
+	@echo "making $@ from $<"
+	@$(SED) < $< \
+	  -e "s|%abs_top_srcdir%|${abs_top_srcdir}|" \
+	  -e "s|%top_srcdir%|${top_srcdir}|" \
+	  -e "s|%OCTAVE_HOME%|${prefix}|" \
+	  -e "s|%OCTAVE_VERSION%|${version}|" \
+	  -e "s|%TEXINFO_COLAMD%|${TEXINFO_COLAMD}|" \
+	  -e "s|%TEXINFO_CHOLMOD%|${TEXINFO_CHOLMOD}|" \
+	  -e "s|%TEXINFO_UMFPACK%|${TEXINFO_UMFPACK}|" \
+	  -e "s|%TEXINFO_QHULL%|${TEXINFO_QHULL}|" > $@-t
+	$(simple_move_if_change_rule)
+
+../BUGS ../INSTALL.OCTAVE:
+	$(MAKE) -C interpreter ../$@
+.PHONY: ../BUGS ../INSTALL.OCTAVE