diff Makefile.am @ 12154:22c99c8cfcb6

Add Makefile rules to auto-generate AUTHORS file from contributors.texi
author Rik <octave@nomad.inbox5.com>
date Mon, 24 Jan 2011 21:41:24 -0800
parents fd0a3ac60b0e
children 1eba19d57fa4
line wrap: on
line diff
--- a/Makefile.am	Mon Jan 24 14:57:07 2011 -0500
+++ b/Makefile.am	Mon Jan 24 21:41:24 2011 -0800
@@ -26,7 +26,7 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
-BUILT_DISTFILES = BUGS INSTALL.OCTAVE
+BUILT_DISTFILES = AUTHORS BUGS INSTALL.OCTAVE
 
 EXTRA_DIST = \
   BUGS \
@@ -101,8 +101,9 @@
 noinst_SCRIPTS = run-octave
 
 INFO_FILES = \
-  INSTALL.OCTAVE \
-  BUGS
+  AUTHORS \
+  BUGS \
+  INSTALL.OCTAVE
 
 CLEANFILES = $(bin_PROGRAMS) $(bin_SCRIPTS) $(BUILT_SOURCES)
 
@@ -148,9 +149,9 @@
 	  cp $< $@; \
 	fi
 
-BUGS INSTALL.OCTAVE:
+AUTHORS BUGS INSTALL.OCTAVE:
 	$(MAKE) -C doc ../$@
-.PHONY: BUGS INSTALL.OCTAVE
+.PHONY: AUTHORS BUGS INSTALL.OCTAVE
 
 octetc_DATA = NEWS