diff etc/icons/Makefile.am @ 18913:ab7d81d5fbdf

build: Create octave.desktop even when --disable-docs configured (bug #42720). * etc/icons/Makefile.am, etc/icons/octave-logo.ico, etc/icons/octave-logo.png, etc/icons/octave-logo.svg, etc/icons/octave-sombrero.png, etc/icons/octave.desktop.in, etc/icons/octave_branding_samples.svg: Move doc/icons files to /etc/icons directory. * Makefile.am: Add etc/icons to list of SUBDIRS to build. * configure.ac: Change doc/icons to etc/icons. * doc/Makefile.am: Remove icons from list of SUBDIRS to build.
author Rik <rik@octave.org>
date Sun, 13 Jul 2014 19:46:57 -0700
parents doc/icons/Makefile.am@d63878346099
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/etc/icons/Makefile.am	Sun Jul 13 19:46:57 2014 -0700
@@ -0,0 +1,56 @@
+# Makefile for Octave's doc/icons directory
+#
+# Copyright (C) 2012-2013 John W. Eaton
+#
+# This file is part of Octave.
+# 
+# Octave is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+# 
+# Octave is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+# for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with Octave; see the file COPYING.  If not, see
+# <http://www.gnu.org/licenses/>.
+
+include $(top_srcdir)/build-aux/common.mk
+
+IMAGE_FILES = \
+  octave-logo.ico \
+  octave-logo.png \
+  octave-logo.svg \
+  octave-sombrero.png
+
+image_DATA = $(IMAGE_FILES)
+
+all-local: octave.desktop
+
+octave.desktop: octave.desktop.in Makefile
+	@echo "making $@ from $<"
+	$(SED) < $< > $@-t \
+	  -e "s|%OCTAVE_IMAGEDIR%|${imagedir}|" \
+	  -e "s|%OCTAVE_PREFIX%|${prefix}|"
+	mv $@-t $@
+
+install-data-local:
+	-if test -n "$(DESKTOP_FILE_INSTALL)"; then \
+	  $(DESKTOP_FILE_INSTALL) --dir=$(DESTDIR)$(datadir)/applications \
+	    --vendor www.octave.org octave.desktop; \
+	fi
+
+uninstall-local:
+	if test -n "$(DESKTOP_FILE_INSTALL)"; then \
+	  rm -f $(DESTDIR)$(datadir)/applications/www.octave.org-octave.desktop; \
+	fi
+
+EXTRA_DIST = \
+  $(IMAGE_FILES) \
+  octave.desktop.in
+
+CLEANFILES = octave.desktop
+