diff src/Makefile.am @ 15107:03381a36f70d

generate convenience libraries for new parse-tree and interpfcn subdirectories * src/Makefile.am (liboctinterp_la_SOURCES): Include octave.cc in the list, not $(DIST_SRC). (liboctinterp_la_LIBADD): Include octave-value/liboctave-value.la, parse-tree/libparse-tree.la, interp-core/libinterp-core.la, interpfcn/libinterpfcn.la, and corefcn/libcorefcn.la in the list. * src/interp-core/module.mk (noinst_LTLIBRARIES): Add interp-core/libinterp-core.la to the list. (interp_core_libinterp_core_la_SOURCES): New variable. * src/interpfcn/module.mk (noinst_LTLIBRARIES): Add interpfcn/libinterpfcn.la to the list. (interpfcn_libinterpfcn_la_SOURCES): New variable. * src/parse-tree/module.mk (noinst_LTLIBRARIES): Add parse-tree/libparse-tree.la to the list. (parse_tree_libparse_tree_la_SOURCES): New variable. * src/octave-value/module.mk (noinst_LTLIBRARIES): Add octave-value/liboctave-value.la to the list. (octave_value_liboctave_value_la_SOURCES): New variable.
author John W. Eaton <jwe@octave.org>
date Sun, 05 Aug 2012 09:04:30 -0400
parents 8523df595d42
children 28ffdc42b550 9db33c1f6f5f
line wrap: on
line diff
--- a/src/Makefile.am	Sat Aug 04 00:19:07 2012 -0500
+++ b/src/Makefile.am	Sun Aug 05 09:04:30 2012 -0400
@@ -172,7 +172,7 @@
 endif
 
 liboctinterp_la_SOURCES = \
-  $(DIST_SRC) \
+  octave.cc \
   $(OPERATORS_SRC) \
   $(TEMPLATE_INST_SRC)
 
@@ -192,6 +192,11 @@
 include link-deps.mk
 
 liboctinterp_la_LIBADD = \
+  octave-value/liboctave-value.la \
+  parse-tree/libparse-tree.la \
+  interp-core/libinterp-core.la \
+  interpfcn/libinterpfcn.la \
+  corefcn/libcorefcn.la \
   ../liboctave/liboctave.la \
   ../libcruft/libcruft.la \
   $(LIBOCTINTERP_LINK_DEPS)