diff configure.in @ 5844:034cdbd34c0a

[project @ 2006-06-07 15:38:58 by jwe]
author jwe
date Wed, 07 Jun 2006 15:38:58 +0000
parents ecb61a521d5b
children 68f8017ef077
line wrap: on
line diff
--- a/configure.in	Tue Jun 06 15:10:08 2006 +0000
+++ b/configure.in	Wed Jun 07 15:38:58 2006 +0000
@@ -29,15 +29,15 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.512 $)
+AC_REVISION($Revision: 1.513 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
 
+OCTAVE_HOST_TYPE
+
 AC_DEFINE(OCTAVE_SOURCE, 1, [Define if this is Octave.])
   
-OCTAVE_HOST_TYPE
-
 AC_GNU_SOURCE
 
 AC_AIX
@@ -48,7 +48,7 @@
 sepchar=:
 AC_ARG_WITH(sepchar,
   [AS_HELP_STRING([--with-sepchar=<char>],
-	[use <char> as the path separation character])])
+     [use <char> as the path separation character])])
 case $with_sepchar in
   yes | "")
     case "$canonical_host_type" in
@@ -104,14 +104,15 @@
 ### Allow the user to force us to use f2c.
 
 AC_ARG_WITH(f2c,
-  [  --with-f2c              use f2c even if Fortran compiler is available],
+  [AS_HELP_STRING([--with-f2c],
+     [use f2c even if Fortran compiler is available])],
   [if test "$withval" = no; then use_f2c=false; else use_f2c=true; fi],
   use_f2c=false)
 
 ### Allow the user to force us to use f77.
 
 AC_ARG_WITH(f77,
-  [  --with-f77              use f77 to compile Fortran subroutines],
+  [AS_HELP_STRING([--with-f77], [use f77 to compile Fortran subroutines])],
   [if test "$withval" = no; then use_f77=false; else use_f77=true; fi],
   use_f77=false)
 
@@ -123,34 +124,14 @@
   AC_MSG_WARN($warn_f2c_and_f77)
   use_f2c=false])
 
-dnl ### Allow the user disable support for plplot.
-dnl 
-dnl # USE_PLPLOT=true
-dnl # PLPLOT_DIR=plplot
-dnl # LIBPLPLOT='$(TOPDIR)/plplot/libplplot.$(LIBEXT)
-USE_PLPLOT=false
-PLPLOT_DIR=""
-LIBPLPLOT=""
-dnl AC_ARG_ENABLE(plplot,
-dnl   [  --enable-plplot         use plplot for plotting (default is yes)],
-dnl   [if test "$enableval" = no; then
-dnl      USE_PLPLOT=false;
-dnl      LIBPLPLOT="";
-dnl      PLPLOT_DIR="";
-dnl    fi], [])
-dnl if $USE_PLPLOT; then
-dnl   AC_DEFINE(USE_PLPLOT, 1, [Define to use plplot.])
-dnl fi
-AC_SUBST(LIBPLPLOT)
-AC_SUBST(PLPLOT_DIR)
-
 ### Make it possible to have Octave's array and matrix classes do bounds
 ### checking on element references.  This slows some operations down a
 ### bit, so it is turned off by default.
 
 BOUNDS_CHECKING=false
 AC_ARG_ENABLE(bounds-check,
-  [  --enable-bounds-check   for internal array classes (default is no)],
+  [AS_HELP_STRING([--enable-bounds-check],
+     [for internal array classes (default is no)])],
   [if test "$enableval" = yes; then BOUNDS_CHECKING=true; fi], [])
 if $BOUNDS_CHECKING; then
   AC_DEFINE(BOUNDS_CHECKING, 1, [Define to use internal bounds checking.])
@@ -161,7 +142,8 @@
 USE_64_BIT_IDX_T=false
 OCTAVE_IDX_TYPE=int
 AC_ARG_ENABLE(64,
-  [  --enable-64             use 64-bit integer for array dimensions and indexing],
+  [AS_HELP_STRING([--enable-64],
+     [use 64-bit integer for array dimensions and indexing])],
   [if test "$enableval" = yes; then USE_64_BIT_IDX_T=true; fi], [])
 if $USE_64_BIT_IDX_T; then
   AC_CHECK_SIZEOF(void *)
@@ -193,7 +175,7 @@
 ### the GNU libc.  Since I'm not sure how to test whether we are using
 ### GNU libc, just disable them for all platforms.
 
-AC_MSG_RESULT([defining __NO_MATH_INLINES avoids buggy GNU libc exp function])
+AC_MSG_NOTICE([defining __NO_MATH_INLINES avoids buggy GNU libc exp function])
 AC_DEFINE(__NO_MATH_INLINES, 1, [Define if your version of GNU libc has buggy inline assembly code for math functions like exp.])
 
 ### See which C++ compiler to use (we expect to find g++).
@@ -245,7 +227,7 @@
   2.*)
     if test -z "$LDFLAGS"; then
       LDFLAGS="-g"
-      AC_MSG_RESULT([defining LDFLAGS to be $LDFLAGS])
+      AC_MSG_NOTICE([defining LDFLAGS to be $LDFLAGS])
     fi
   ;;
   1.*)
@@ -290,7 +272,7 @@
       OCTAVE_CC_FLAG(-mieee-fp, [
         ieee_fp_flag=-mieee-fp
         XTRA_CFLAGS="$XTRA_CFLAGS -mieee-fp"
-        AC_MSG_RESULT([adding -mieee-fp to XTRA_CFLAGS])])
+        AC_MSG_NOTICE([adding -mieee-fp to XTRA_CFLAGS])])
 
 ###      OCTAVE_CC_FLAG(-ffloat-store, [
 ###        float_store_flag=-ffloat-store
@@ -301,7 +283,7 @@
       OCTAVE_CXX_FLAG(-mieee-fp, [
 	ieee_fp_flag=-mieee-fp
 	XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee-fp"
-	AC_MSG_RESULT([adding -mieee-fp to XTRA_CXXFLAGS])])
+	AC_MSG_NOTICE([adding -mieee-fp to XTRA_CXXFLAGS])])
 
 ###      OCTAVE_CXX_FLAG(-ffloat-store, [
 ###        float_store_flag=-ffloat-store
@@ -314,23 +296,23 @@
       OCTAVE_CC_FLAG(-mieee, [
 	ieee_fp_flag=-mieee
 	XTRA_CFLAGS="$XTRA_CFLAGS -mieee"
-	AC_MSG_RESULT([adding -mieee to XTRA_CFLAGS])])
+	AC_MSG_NOTICE([adding -mieee to XTRA_CFLAGS])])
     else
       OCTAVE_CC_FLAG(-ieee, [
 	ieee_fp_flag=-ieee
 	XTRA_CFLAGS="$XTRA_CFLAGS -ieee"
-	AC_MSG_RESULT([adding -ieee to XTRA_CFLAGS])])
+	AC_MSG_NOTICE([adding -ieee to XTRA_CFLAGS])])
     fi
     if test "$GXX" = yes; then
       OCTAVE_CXX_FLAG(-mieee, [
 	ieee_fp_flag=-mieee
 	XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee"
-	AC_MSG_RESULT([adding -mieee to XTRA_CXXFLAGS])])
+	AC_MSG_NOTICE([adding -mieee to XTRA_CXXFLAGS])])
     else
       OCTAVE_CXX_FLAG(-ieee, [
 	ieee_fp_flag=-ieee
 	XTRA_CXXFLAGS="$XTRA_CXXFLAGS -ieee"
-	AC_MSG_RESULT([adding -ieee to XTRA_CXXFLAGS])])
+	AC_MSG_NOTICE([adding -ieee to XTRA_CXXFLAGS])])
     fi
   ;;
   *ibm-aix4*)
@@ -353,7 +335,7 @@
   ;;
 esac
 if test -n "$LD_STATIC_FLAG"; then
-  AC_MSG_RESULT([defining LD_STATIC_FLAG to be $LD_STATIC_FLAG])
+  AC_MSG_NOTICE([defining LD_STATIC_FLAG to be $LD_STATIC_FLAG])
 fi
 AC_SUBST(LD_STATIC_FLAG)
 
@@ -446,7 +428,7 @@
 
 WITH_ZLIB=true
 AC_ARG_WITH(zlib,
-  [  --without-zlib          don't use zlib],
+  [AS_HELP_STRING([--without-zlib], [don't use zlib])],
   with_zlib=$withval, with_zlib=yes)
 
 zlib_lib=
@@ -472,7 +454,7 @@
 
   WITH_HDF5=true
   AC_ARG_WITH(hdf5,
-    [  --without-hdf5          don't use HDF5],
+    [AS_HELP_STRING([--without-hdf5], [don't use HDF5])],
     with_hdf5=$withval, with_hdf5=yes)
 
   hdf5_lib=
@@ -516,7 +498,8 @@
 AC_SUBST(FFTW_LIBS)
 
 AC_ARG_WITH(fftw, 
-  [  --without-fftw          use included fftpack instead of installed fftw],
+  [AS_HELP_STRING([--without-fftw],
+     [use included fftpack instead of installed fftw])],
   with_fftw=$withval, with_fftw=yes)
 
 if test "$with_fftw" = yes; then
@@ -536,7 +519,7 @@
 # Checks for GLPK header and library.
 
 AC_ARG_WITH(glpk,
-  [  --without-glpk          don't use GLPK],
+  [AS_HELP_STRING([--without-glpk], [don't use GLPK])],
   with_glpk=$withval, with_glpk=yes)
 
 glpk_lib=
@@ -580,7 +563,7 @@
   else
     F77="$with_f77"
   fi
-  AC_MSG_RESULT([defining F77 to be $F77])
+  AC_MSG_NOTICE([defining F77 to be $F77])
 elif $use_f2c; then
   F77=
   if test "$with_f2c" = yes; then
@@ -588,7 +571,7 @@
   else
     F2C="$with_f2c"
   fi
-  AC_MSG_RESULT([defining F2C to be $F2C])
+  AC_MSG_NOTICE([defining F2C to be $F2C])
 fi
 
 if test "x$FFLAGS" = x; then
@@ -628,7 +611,7 @@
       ;;
     esac
     if test -n "$FFLAGS"; then
-      AC_MSG_RESULT([defining FFLAGS to be $FFLAGS])
+      AC_MSG_NOTICE([defining FFLAGS to be $FFLAGS])
     fi
     have_fortran_compiler=true
   else
@@ -732,7 +715,8 @@
 AC_SUBST(UMFPACK_LIBS)
 
 AC_ARG_WITH(umfpack,
-  [  --without-umfpack       don't use UMFPACK, disable some sparse functionality],
+  [AS_HELP_STRING([--without-umfpack],
+     [don't use UMFPACK, disable some sparse functionality])],
   with_umfpack=$withval, with_umfpack=yes)
 
 warn_umfpack="UMFPACK not found.  This will result in some lack of functionality for sparse matrices."
@@ -769,7 +753,8 @@
 AC_SUBST(COLAMD_LIBS)
 
 AC_ARG_WITH(colamd,
-  [  --without-colamd        don't use COLAMD, disable some sparse functionality],
+  [AS_HELP_STRING([--without-colamd],
+     [don't use COLAMD, disable some sparse functionality])],
   with_colamd=$withval, with_colamd=yes)
 
 warn_colamd="COLAMD not found. This will result in some lack of functionality for sparse matrices."
@@ -791,7 +776,8 @@
 AC_SUBST(CCOLAMD_LIBS)
 
 AC_ARG_WITH(ccolamd,
-  [  --without-ccolamd       don't use CCOLAMD, disable some sparse functionality],
+  [AS_HELP_STRING([--without-ccolamd],
+     [don't use CCOLAMD, disable some sparse functionality])],
   with_ccolamd=$withval, with_ccolamd=yes)
 
 warn_ccolamd="CCOLAMD not found. This will result in some lack of functionality for sparse matrices."
@@ -810,7 +796,8 @@
 AC_SUBST(CHOLMOD_LIBS)
 
 AC_ARG_WITH(cholmod,
-  [  --without-cholmod       don't use CHOLMOD, disable some sparse functionality],
+  [AS_HELP_STRING([--without-cholmod],
+     [don't use CHOLMOD, disable some sparse functionality])],
   with_cholmod=$withval, with_cholmod=yes)
 
 warn_cholmod="CHOLMOD not found. This will result in some lack of functionality for sparse matrices."
@@ -854,7 +841,8 @@
 AC_SUBST(CXSPARSE_LIBS)
 
 AC_ARG_WITH(cxsparse,
-  [  --without-cxsparse       don't use CXSparse, disable some sparse functionality],
+  [AS_HELP_STRING([--without-cxsparse],
+     [don't use CXSparse, disable some sparse functionality])],
   with_cxsparse=$withval, with_cxsparse=yes)
 
 warn_cxsparse="CXSparse not found. This will result in some lack of functionality for sparse matrices."
@@ -874,7 +862,7 @@
 ### Enable creation of static libraries.
 
 AC_ARG_ENABLE(static,
-  [  --enable-static         create static libraries],
+  [AS_HELP_STRING([--enable-static], [create static libraries])],
   [if test "$enableval" = no; then STATIC_LIBS=false;
    else STATIC_LIBS=true; fi],
   STATIC_LIBS=false)
@@ -884,7 +872,8 @@
 ### gcc on some systems.
 
 AC_ARG_ENABLE(shared,
-  [  --enable-shared         create shared libraries (not all systems)],
+  [AS_HELP_STRING([--enable-shared],
+     [create shared libraries (not all systems)])],
   [if test "$enableval" = no; then SHARED_LIBS=false;
    else SHARED_LIBS=true; fi],
   SHARED_LIBS=true)
@@ -896,7 +885,8 @@
 ### example, OS X and Windows).
 
 AC_ARG_ENABLE(dl,
-  [  --enable-dl             create shared libraries (not all systems)],
+  [AS_HELP_STRING([--enable-dl],
+     [create shared libraries (not all systems)])],
   [if test "$enableval" = no; then ENABLE_DYNAMIC_LINKING=false;
    else ENABLE_DYNAMIC_LINKING=true; fi],
   ENABLE_DYNAMIC_LINKING=true)
@@ -908,8 +898,8 @@
 fi
 
 AC_ARG_ENABLE(rpath,
-  [  --enable-rpath          override the default link options for rpath;
-                            e.g., --enable-rpath='-rpath $(octlibdir)'],
+  [AS_HELP_STRING([--enable-rpath],
+     [override the default link options for rpath; e.g., --enable-rpath='-rpath $(octlibdir)'])],
   [ if test "$enableval" = no; then use_rpath=false;
     else
       use_rpath=true
@@ -1063,28 +1053,28 @@
   RLD_FLAG=""
 fi
 
-AC_MSG_RESULT([defining FPICFLAG to be $FPICFLAG])
-AC_MSG_RESULT([defining CPICFLAG to be $CPICFLAG])
-AC_MSG_RESULT([defining CXXPICFLAG to be $CXXPICFLAG])
-AC_MSG_RESULT([defining SHLEXT to be $SHLEXT])
-AC_MSG_RESULT([defining SHLLIB to be $SHLLIB])
-AC_MSG_RESULT([defining SHLBIN to be $SHLBIN])
-AC_MSG_RESULT([defining SHLEXT_VER to be $SHLEXT_VER])
-AC_MSG_RESULT([defining SHLLIB_VER to be $SHLLIB_VER])
-AC_MSG_RESULT([defining SHLBIN_VER to be $SHLBIN_VER])
-AC_MSG_RESULT([defining SHLLINKEXT to be $SHLLINKEXT])
-AC_MSG_RESULT([defining DLFCN_DIR to be $DLFCN_DIR])
-AC_MSG_RESULT([defining SH_LD to be $SH_LD])
-AC_MSG_RESULT([defining SH_LDFLAGS to be $SH_LDFLAGS])
-AC_MSG_RESULT([defining DL_LD to be $DL_LD])
-AC_MSG_RESULT([defining DL_LDFLAGS to be $DL_LDFLAGS])
-AC_MSG_RESULT([defining MKOCTFILE_DL_LDFLAGS to be $MKOCTFILE_DL_LDFLAGS])
-AC_MSG_RESULT([defining SONAME_FLAGS to be $SONAME_FLAGS])
-AC_MSG_RESULT([defining NO_OCT_FILE_STRIP to be $NO_OCT_FILE_STRIP])
-AC_MSG_RESULT([defining RLD_FLAG to be $RLD_FLAG])
-AC_MSG_RESULT([defining TEMPLATE_AR to be $TEMPLATE_AR])
-AC_MSG_RESULT([defining TEMPLATE_ARFLAGS to be $TEMPLATE_ARFLAGS])
-AC_MSG_RESULT([defining library_path_var to be $library_path_var])
+AC_MSG_NOTICE([defining FPICFLAG to be $FPICFLAG])
+AC_MSG_NOTICE([defining CPICFLAG to be $CPICFLAG])
+AC_MSG_NOTICE([defining CXXPICFLAG to be $CXXPICFLAG])
+AC_MSG_NOTICE([defining SHLEXT to be $SHLEXT])
+AC_MSG_NOTICE([defining SHLLIB to be $SHLLIB])
+AC_MSG_NOTICE([defining SHLBIN to be $SHLBIN])
+AC_MSG_NOTICE([defining SHLEXT_VER to be $SHLEXT_VER])
+AC_MSG_NOTICE([defining SHLLIB_VER to be $SHLLIB_VER])
+AC_MSG_NOTICE([defining SHLBIN_VER to be $SHLBIN_VER])
+AC_MSG_NOTICE([defining SHLLINKEXT to be $SHLLINKEXT])
+AC_MSG_NOTICE([defining DLFCN_DIR to be $DLFCN_DIR])
+AC_MSG_NOTICE([defining SH_LD to be $SH_LD])
+AC_MSG_NOTICE([defining SH_LDFLAGS to be $SH_LDFLAGS])
+AC_MSG_NOTICE([defining DL_LD to be $DL_LD])
+AC_MSG_NOTICE([defining DL_LDFLAGS to be $DL_LDFLAGS])
+AC_MSG_NOTICE([defining MKOCTFILE_DL_LDFLAGS to be $MKOCTFILE_DL_LDFLAGS])
+AC_MSG_NOTICE([defining SONAME_FLAGS to be $SONAME_FLAGS])
+AC_MSG_NOTICE([defining NO_OCT_FILE_STRIP to be $NO_OCT_FILE_STRIP])
+AC_MSG_NOTICE([defining RLD_FLAG to be $RLD_FLAG])
+AC_MSG_NOTICE([defining TEMPLATE_AR to be $TEMPLATE_AR])
+AC_MSG_NOTICE([defining TEMPLATE_ARFLAGS to be $TEMPLATE_ARFLAGS])
+AC_MSG_NOTICE([defining library_path_var to be $library_path_var])
 AC_SUBST(FPICFLAG)
 AC_SUBST(CPICFLAG)
 AC_SUBST(CXXPICFLAG)
@@ -1235,8 +1225,8 @@
   readlink rename resolvepath rindex rmdir round select setgrent \
   setpwent setvbuf sigaction siglongjmp sigpending sigprocmask \
   sigsuspend stat strcasecmp strdup strerror strftime stricmp \
-  strncasecmp strnicmp strptime symlink tempnam umask uname unlink \
-  usleep vfprintf vsprintf vsnprintf waitpid)
+  strncasecmp strnicmp strptime strsignal symlink tempnam umask \
+  uname unlink usleep vfprintf vsprintf vsnprintf waitpid)
 
 OCTAVE_SMART_PUTENV
 
@@ -1350,7 +1340,7 @@
 ### Emacs 19.
 
 AC_MSG_CHECKING(for struct timeval)
-AC_TRY_COMPILE([#ifdef TIME_WITH_SYS_TIME
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef TIME_WITH_SYS_TIME
 #include <sys/time.h>
 #include <time.h>
 #else
@@ -1359,7 +1349,7 @@
 #else
 #include <time.h>
 #endif
-#endif], [static struct timeval x; x.tv_sec = x.tv_usec;],
+#endif]], [[static struct timeval x; x.tv_sec = x.tv_usec;]])],
   [AC_MSG_RESULT(yes)
    HAVE_TIMEVAL=yes
    AC_DEFINE(HAVE_TIMEVAL, 1, [Define if struct timeval is defined.])],
@@ -1405,11 +1395,11 @@
   m68k-hp-hpux*)
   ;;
   *-*-sco*)
-    AC_MSG_RESULT([defining SCO to be 1])
+    AC_MSG_NOTICE([defining SCO to be 1])
     AC_DEFINE(SCO, 1, [Define if using an SCO system.])
-    AC_MSG_RESULT([forcing HAVE_ISINF for SCO])
+    AC_MSG_NOTICE([forcing HAVE_ISINF for SCO])
     AC_DEFINE(HAVE_ISINF, 1, [Define if you have isinf().])
-    AC_MSG_RESULT([forcing HAVE_ISNAN for SCO])
+    AC_MSG_NOTICE([forcing HAVE_ISNAN for SCO])
     AC_DEFINE(HAVE_ISNAN, 1, [Define if you have isnan().])
   ;;
   *)
@@ -1467,16 +1457,13 @@
 ### Signal stuff.
 
 AC_TYPE_SIGNAL
-AC_CHECK_DECL([sys_siglist],
-  [AC_DEFINE(SYS_SIGLIST_DECLARED, 1, [Define if your system has a declaration of sys_siglist.])],
-  [AC_CHECK_DECLS([sys_siglist])], [#include <signal.h>])
-AC_MSG_CHECKING([for sys_siglist variable])
-AC_LINK_IFELSE([[#include <stdio.h>]],
-  [[extern char *sys_siglist[]; printf ("%s\n", sys_siglist[1]);]])],
-  [AC_MSG_RESULT(yes)
-   AC_DEFINE(HAVE_SYS_SIGLIST, 1,
-     [Define if your system has a sys_siglist variable.])],
-  [AC_MSG_RESULT(no)])
+AC_CHECK_DECLS([sys_siglist], [], [],
+[#include <signal.h>
+/* NetBSD declares sys_siglist in unistd.h.  */
+#if HAVE_UNISTD_H
+# include <unistd.h>
+#endif
+])
 OCTAVE_SIGNAL_CHECK
 OCTAVE_REINSTALL_SIGHANDLERS
 
@@ -1558,7 +1545,7 @@
     UGLY_DEFS=`echo $DEFS | sed 's,\\",\\\\\\\\\\\\\\\\\\",g'`
   ;;
 esac
-AC_MSG_RESULT([defining UGLY_DEFS to be $UGLY_DEFS])
+AC_MSG_NOTICE([defining UGLY_DEFS to be $UGLY_DEFS])
 AC_SUBST(UGLY_DEFS)
 
 ### Maybe add -Wall, -W, and -Wshadow to compiler flags now that we're
@@ -1598,7 +1585,8 @@
   -Wwrite-strings -Weffc++ -Wenum-clash"
 
 AC_ARG_ENABLE(picky-flags,
-  [  --enable-picky-flags    add picky options to CFLAGS, CXXFLAGS, FFLAGS],
+  [AS_HELP_STRING([--enable-picky-flags],
+     [add extra warning options to CFLAGS, CXXFLAGS, FFLAGS])],
   [if test "$enableval" = no; then
      true
    elif test "$enableval" = yes; then
@@ -1629,10 +1617,6 @@
 
 AC_CONFIG_SUBDIRS(scripts)
 
-if test "x$PLPLOT_DIR" = xplplot; then
-  AC_CONFIG_SUBDIRS(plplot)
-fi
-
 ### Some things to add to the bottom of config.h.
 
 AH_BOTTOM([
@@ -1771,7 +1755,7 @@
   FORT="$F77 $FFLAGS"
 fi
 
-AC_MSG_RESULT([
+AC_MSG_NOTICE([
 
 Octave is now configured for $canonical_host_type
 
@@ -1928,7 +1912,7 @@
 fi
 
 if $warn_msg_printed; then
-  AC_MSG_RESULT([])
+  AC_MSG_NOTICE([])
 fi
 
 ### End of configure.