diff configure.ac @ 17241:03a666018e0f

build: Detect new GLPK API features required since changeset 54e251e699bb * m4/acinclude.m4 (OCTAVE_CHECK_LIB_GLPK_OK): New macro to detect the newest GLPK API features required by Octave. * configure.ac: Call it and disable glpk if the library is not ok.
author Mike Miller <mtmiller@ieee.org>
date Tue, 13 Aug 2013 21:38:12 -0400
parents bc20614022aa
children 3a9efb68272d
line wrap: on
line diff
--- a/configure.ac	Wed Aug 14 01:54:34 2013 +0100
+++ b/configure.ac	Tue Aug 13 21:38:12 2013 -0400
@@ -886,7 +886,12 @@
 LIBS="$Z_LDFLAGS $Z_LIBS $LIBS"
 OCTAVE_CHECK_LIB(glpk, GLPK,
   [GLPK library not found.  The glpk function for solving linear programs will be disabled.],
-  [glpk/glpk.h glpk.h], [glp_simplex])
+  [glpk/glpk.h glpk.h], [glp_simplex], [], [],
+  [warn_glpk=
+   OCTAVE_CHECK_LIB_GLPK_OK(
+    [TEXINFO_GLPK="@set HAVE_GLPK"
+    AC_DEFINE(HAVE_GLPK, 1, [Define to 1 if GLPK is available.])],
+    [warn_glpk="GLPK library found, but does not seem to work properly -- disabling glpk function"])])
 LIBS="$save_LIBS"
 CPPFLAGS="$save_CPPFLAGS"