diff configure.ac @ 19383:043440fa7006 stable

configure.ac: Respect without-z and without-qrupdate options when config.cache exists. * configure.ac: Check that Z lib and QRUPDATE lib are desired, rather than the previous result in cache variable, to determine if AC_DEFINE should execute.
author Rik <rik@octave.org>
date Sun, 23 Nov 2014 15:15:02 -0800
parents 88847d5d1a96
children 98c7fa559d75 446c46af4b42
line wrap: on
line diff
--- a/configure.ac	Sat Nov 22 21:05:53 2014 -0800
+++ b/configure.ac	Sun Nov 23 15:15:02 2014 -0800
@@ -784,7 +784,7 @@
   [zlib.h], [gzclearerr])
 
 ### Also define HAVE_ZLIB if libz is found.
-if test $octave_cv_lib_z = yes; then
+if test -z "$warn_z"; then
   AC_DEFINE(HAVE_ZLIB, 1, [Define to 1 if ZLIB is available.])
 fi
 
@@ -1428,7 +1428,8 @@
   [sqr1up],
   [Fortran 77], [don't use qrupdate, disable QR & Cholesky updating functions])
 
-if test $octave_cv_lib_qrupdate = yes; then
+## Additional check to see if qrupdate lib found supports LU updates
+if test -z "$warn_qrupdate"; then
   AC_CACHE_CHECK([for slup1up in $QRUPDATE_LIBS],
     [octave_cv_func_slup1up],
     [LIBS="$LIBS $QRUPDATE_LIBS"