diff configure.in @ 4189:047d21dd1890

[project @ 2002-11-19 21:08:57 by jwe]
author jwe
date Tue, 19 Nov 2002 21:08:57 +0000
parents 4d1d7c51205c
children bc0edad7dda7
line wrap: on
line diff
--- a/configure.in	Tue Nov 19 20:17:44 2002 +0000
+++ b/configure.in	Tue Nov 19 21:08:57 2002 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.390 $)
+AC_REVISION($Revision: 1.391 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -926,23 +926,25 @@
   if test $ac_cv_header_Mach_O_dyld_h = yes; then
     dyld_api=true
   else 
-    AC_CHECK_LIB(dl, dlopen)
-    AC_CHECK_FUNCS(dlopen dlsym dlerror dlclose)
-    if test $ac_cv_func_dlclose = yes && test $ac_cv_func_dlerror = yes \
-      && test $ac_cv_func_dlopen = yes && test $ac_cv_func_dlsym = yes; then
-      dlopen_api=true
+    AC_CHECK_LIB(dld, shl_load)
+    AC_CHECK_FUNCS(shl_load shl_findsym)
+    if test $ac_cv_func_shl_load = yes \
+      && test $ac_cv_func_shl_findsym = yes; then
+      shl_load_api=true
     else
-      AC_CHECK_LIB(dld, shl_load)
-      AC_CHECK_FUNCS(shl_load shl_findsym)
-      if test $ac_cv_func_shl_load = yes \
-	&& test $ac_cv_func_shl_findsym = yes; then
-	shl_load_api=true
+      AC_CHECK_LIB(wsock32, LoadLibrary)
+      AC_CHECK_FUNCS(LoadLibrary)
+      if test $ac_cv_func_loadlibrary = yes; then
+        loadlibrary_api=true
       else
-	AC_CHECK_LIB(wsock32, LoadLibrary)
-	AC_CHECK_FUNCS(LoadLibrary)
-	if test $ac_cv_func_loadlibrary = yes; then
-	  loadlibrary_api=true
-	else
+        AC_CHECK_LIB(dl, dlopen)
+        AC_CHECK_FUNCS(dlopen dlsym dlerror dlclose)
+        if test $ac_cv_func_dlclose = yes \
+          && test $ac_cv_func_dlerror = yes \
+          && test $ac_cv_func_dlopen = yes \
+          && test $ac_cv_func_dlsym = yes; then
+          dlopen_api=true
+        else
 	  case "$canonical_host_type" in
 	    rs6000-ibm-aix* | powerpc-ibm-aix*)
 	      LIBDLFCN="-ldlfcn -ll -lld"