diff configure.ac @ 17797:06a850f83dd4

build: Remove embedded gl2ps. Require gl2ps as external dependency. * NEWS: Announce that gl2ps is no longer distributed with Octave. * build-aux/common.mk: New AC_SUBST macro GL2PS_LIBS. * configure.ac: When building native graphics, test for gl2ps.h header. If not found, print a warning and disable printing of FLTK figures. * libinterp/corefcn/gl2ps-renderer.cc, libinterp/corefcn/gl2ps-renderer.h: Only compile files if HAVE_GL2PS_H is true. * libinterp/dldfcn/__init_fltk__.cc(draw): Use #ifdef HAVE_GL2PS_H to either print figure, or issue a warning when gl2ps is not available. * libinterp/link-deps.mk: Add GL2PS_LIBS to libinter link dependencies * libinterp/corefcn/module.mk: Remove gl2ps.h, gl2ps.c from build system. * libinterp/corefcn/gl2ps.c, libinterp/corefcn/gl2ps.h: Removed from distribution.
author Rik <rik@octave.org>
date Tue, 29 Oct 2013 15:16:23 -0700
parents 26e9312e6928
children e6317049225b
line wrap: on
line diff
--- a/configure.ac	Tue Oct 29 16:29:46 2013 -0400
+++ b/configure.ac	Tue Oct 29 15:16:23 2013 -0700
@@ -1190,6 +1190,15 @@
 AC_SUBST(GRAPHICS_CFLAGS)
 AC_SUBST(GRAPHICS_LIBS)
 
+## Check for gl2ps which is required for printing with OpenGL graphics
+if test $native_graphics = yes; then
+  AC_CHECK_HEADERS([gl2ps.h],
+    [GL2PS_LIBS="-lgl2ps"],
+    [AC_MSG_WARN([gl2ps library not found.  OpenGL printing is disabled.])])
+fi
+
+AC_SUBST(GL2PS_LIBS)
+
 ### Start determination of shared vs. static libraries
 
 ## Use -static if compiling on Alpha OSF/1 1.3 systems.