diff configure.in @ 2592:0863d2cab514

[project @ 1996-12-14 04:39:00 by jwe]
author jwe
date Sat, 14 Dec 1996 04:39:00 +0000
parents 0f37e1edb234
children 389b1b5af266
line wrap: on
line diff
--- a/configure.in	Sat Dec 14 04:33:21 1996 +0000
+++ b/configure.in	Sat Dec 14 04:39:00 1996 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.242 $)
+AC_REVISION($Revision: 1.243 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -400,7 +400,11 @@
     DLFCN_DIR=dlfcn
   ;;
   hppa*-hp-hpux*)
-    FPICFLAG=+Z
+    if $use_g77; then
+      FPICFLAG=-fPIC
+    else
+      FPICFLAG=+Z
+    fi
     SHLEXT=sl
     RLD_FLAG='-Xlinker +b -Xlinker $(libdir)'
   ;;
@@ -876,7 +880,7 @@
 OCTAVE_STRUCT_GR_PASSWD
 
 TERMLIBS=""
-for termlib in termcap terminfo ncurses curses termlib; do
+for termlib in ncurses curses termcap terminfo termlib; do
   AC_CHECK_LIB(${termlib}, tputs, [TERMLIBS="${TERMLIBS} -l${termlib}"])
   case "${TERMLIBS}" in
     *-l${termlib}*)