diff doc/liboctave/Makefile.am @ 9794:0d4613a736e9

convert build system to use automake and libtool
author John W. Eaton <jwe@octave.org>
date Tue, 10 Nov 2009 15:02:25 -0500
parents
children 02d59b67632f
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/doc/liboctave/Makefile.am	Tue Nov 10 15:02:25 2009 -0500
@@ -0,0 +1,65 @@
+# Makefile for octave's doc/liboctave directory
+#
+# Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004,
+#               2005, 2006, 2007 John W. Eaton
+#
+# This file is part of Octave.
+# 
+# Octave is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+# 
+# Octave is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+# for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with Octave; see the file COPYING.  If not, see
+# <http://www.gnu.org/licenses/>.
+
+TOPDIR = ../..
+
+include ../../common.mk
+
+AM_MAKEINFOFLAGS = -I.. -I$(srcdir) -I$(srcdir)/..
+AM_MAKEINFOHTMLFLAGS = -I.. -I$(srcdir) -I$(srcdir)/..
+
+TEXINFO_TEX = ../texinfo.tex
+
+TEXINPUTS = "..$(PATH_SEPARATOR)$(srcdir)$(PATH_SEPARATOR)$(srcdir)/..$(PATH_SEPARATOR)"
+export TEXINPUTS
+
+info_TEXINFOS = liboctave.texi
+
+liboctave_TEXINFOS = \
+  ../conf.texi \
+  array.texi \
+  bugs.texi \
+  cp-idx.texi \
+  dae.texi \
+  diffeq.texi \
+  error.texi \
+  factor.texi \
+  fn-idx.texi \
+  gpl.texi \
+  install.texi \
+  intro.texi \
+  matvec.texi \
+  nleqn.texi \
+  nlfunc.texi \
+  ode.texi \
+  optim.texi \
+  preface.texi \
+  quad.texi \
+  range.texi
+
+../conf.texi:
+	$(MAKE) -C .. conf.texi
+
+all-local: dvi html pdf ps
+
+EXTRA_DIST = liboctave.dvi liboctave.html liboctave.pdf liboctave.ps
+
+.NOTPARALLEL: