diff configure.ac @ 17878:0d660785098e

work around GCC bug in stl_algo.h (nth_element and sort; bug #40436) * build-aux/stl_algo.h-fixed: New file. * acinclude.m4 (OCTAVE_CHECK_BROKEN_STL_ALGO_H): New macro. * configure.ac: Use it. Set AMCOND_HAVE_BROKEN_STL_ALGO_H. * Makefile.am (bits/stl_algo.h): New target. (BUILT_SOURCES): Add bits/stl_algo.h to the list if AMCOND_HAVE_BROKEN_STL_ALGO_H is true. (EXTRA_DIST): Include built-aux/stl_algo.h-fixed in the list.
author John W. Eaton <jwe@octave.org>
date Thu, 07 Nov 2013 14:03:58 -0500
parents 540d1c122b08
children 11a6c7445a71
line wrap: on
line diff
--- a/configure.ac	Thu Nov 07 12:37:13 2013 -0500
+++ b/configure.ac	Thu Nov 07 14:03:58 2013 -0500
@@ -342,6 +342,7 @@
 
 GCC_VERSION=
 if test "$GCC" = yes; then
+  AC_MSG_CHECKING([C compiler version number])
   gcc_version=`$CC -v 2>&1 | $GREP "^.*gcc version" | \
     $SED -e 's/^.*g.. version *//' -e 's/cygnus-//' -e 's/egcs-//' -e 's/ .*//'`
 
@@ -350,6 +351,7 @@
      OCTAVE_CONFIGURE_WARNING([warn_gcc_version])])
 
   GCC_VERSION=$gcc_version
+  AC_MSG_RESULT([$GCC_VERSION])
 fi
 AC_SUBST(GCC_VERSION)
 
@@ -362,7 +364,8 @@
 
 GXX_VERSION=
 if test "$GXX" = yes; then
-  gxx_version=`$CXX -v 2>&1 | $GREP "^.*g++ version" | \
+  AC_MSG_CHECKING([C++ compiler version number])
+  gxx_version=`$CXX -v 2>&1 | $GREP "^.*g.. version" | \
     $SED -e 's/^.*g.. version *//' -e 's/cygnus-//' -e 's/egcs-//' -e 's/ .*//'`
 
   AX_COMPARE_VERSION([$gxx_version], [lt], [3],
@@ -370,9 +373,14 @@
      OCTAVE_CONFIGURE_WARNING([warn_gxx_version])])
 
   GXX_VERSION=$gxx_version
+  AC_MSG_RESULT([$GXX_VERSION])
 fi
 AC_SUBST(GXX_VERSION)
 
+OCTAVE_CHECK_BROKEN_STL_ALGO_H
+AM_CONDITIONAL([AMCOND_HAVE_BROKEN_STL_ALGO_H],
+  [test $octave_cv_broken_stl_algo_h = yes])
+
 ### Determine the compiler flag necessary to create dependencies
 
 ## Assume GCC.