diff configure.in @ 764:0e146d12d46a

[project @ 1994-10-03 04:14:58 by jwe]
author jwe
date Mon, 03 Oct 1994 04:14:58 +0000
parents 3fc1ccd5a9db
children 29a7b5b6f0dc
line wrap: on
line diff
--- a/configure.in	Mon Oct 03 03:32:07 1994 +0000
+++ b/configure.in	Mon Oct 03 04:14:58 1994 +0000
@@ -21,7 +21,7 @@
 dnl along with Octave; see the file COPYING.  If not, write to the Free
 dnl Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
 dnl
-AC_REVISION($Revision: 1.51 $)dnl
+AC_REVISION($Revision: 1.52 $)dnl
 AC_PREREQ(1.8)dnl
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h kpathsea/c-auto.h)
@@ -552,12 +552,17 @@
 dnl
 XCFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS $GCC_IEEE_FP_FLAG"
-for func in finite isnan isinf
-do
-  trfunc=`echo $func | tr '[a-z]' '[A-Z]'`
-  AC_FUNC_CHECK([$func],
-  AC_DEFINE(HAVE_[$trfunc], 1),
-    AC_COMPILE_CHECK([$func], [#include <math.h>], [
+dnl
+case "$canonical_host_type" in
+  alpha-dec-osf*)
+  ;;
+  *)
+    for func in finite isnan isinf
+    do
+      trfunc=`echo $func | tr '[a-z]' '[A-Z]'`
+      AC_FUNC_CHECK([$func],
+      AC_DEFINE(HAVE_[$trfunc], 1),
+	AC_COMPILE_CHECK([$func], [#include <math.h>], [
 /* The GNU C library defines this for functions which it implements
     to always fail with ENOSYS.  Some functions are actually named
     something starting with __ and the normal name is an alias.  */
@@ -567,9 +572,10 @@
 /* Override any gcc2 internal prototype to avoid an error.  */
 $func (1.0);
 #endif
-],
-      AC_DEFINE(HAVE_[$trfunc], 1), []))dnl
-done
+], AC_DEFINE(HAVE_[$trfunc], 1), []))dnl
+    done
+  ;;
+esac
 dnl
 AC_HAVE_FUNCS(infinity quiet_nan)dnl
 AC_HAVE_FUNCS(erf erfc lgamma)dnl