diff configure.in @ 3126:0f6ec7b761a6

[project @ 1998-01-16 05:15:43 by jwe]
author jwe
date Fri, 16 Jan 1998 05:15:44 +0000
parents 38684be52a3e
children d6ebd123170a
line wrap: on
line diff
--- a/configure.in	Fri Jan 16 05:11:09 1998 +0000
+++ b/configure.in	Fri Jan 16 05:15:44 1998 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.291 $)
+AC_REVISION($Revision: 1.292 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -182,7 +182,6 @@
 ### Do special things for g++.
 
 ADD_CXX_WALL=false
-NO_IMPLICIT_TEMPLATES=
 
 gxx_version=`$CXX -v 2>&1 | grep "^.*g.. version" | \
   sed -e 's/^.*g.. version *//' -e 's/cygnus-//' -e 's/egcs-//'`
@@ -199,8 +198,6 @@
     if test -z "$EXTERN_CXXFLAGS"; then
       ADD_CXX_WALL=true
     fi
-    NO_IMPLICIT_TEMPLATES="-fno-implicit-templates"
-    AC_MSG_RESULT([defining NO_IMPLICIT_TEMPLATES to be $NO_IMPLICIT_TEMPLATES])
   ;;
 changequote(,)dnl
   2.[89].* | 2.[123456789][0123456789].*)
@@ -208,8 +205,6 @@
     if test -z "$EXTERN_CXXFLAGS"; then
       ADD_CXX_WALL=true
     fi
-    NO_IMPLICIT_TEMPLATES="-fno-implicit-templates"
-    AC_MSG_RESULT([defining NO_IMPLICIT_TEMPLATES to be $NO_IMPLICIT_TEMPLATES])
   ;;
   *)
     warn_gxx_only="Octave has only been tested with g++, and I can't find it"
@@ -223,9 +218,6 @@
 fi
 AC_SUBST(CXX_VERSION)
 
-AC_SUBST(HOST_CXXFLAGS)
-AC_SUBST(NO_IMPLICIT_TEMPLATES)
-
 OCTAVE_CXX_NEW_FRIEND_TEMPLATE_DECL
 
 ### See which C compiler to use (we expect to find gcc).
@@ -270,35 +262,44 @@
 ### On Intel systems with gcc, we may need to compile with -mieee-fp to
 ### get full support for IEEE floating point.
 ###
-### On Alpha/OSF systems, wee need -mieee, but that also
-### requires gcc 2.8.x or later.
+### On Alpha/OSF systems, we need -mieee.
 
-GCC_IEEE_FP_FLAG=
+ieee_fp_flag=
 case "$canonical_host_type" in
 changequote(,)dnl
   i[3456789]86-*-*)
 changequote([,])dnl
-    XCFLAGS="$CFLAGS"
-    CFLAGS="$CFLAGS -mieee-fp"
-    AC_TRY_LINK([], [], [GCC_IEEE_FP_FLAG="-mieee-fp"], [])
-    CFLAGS="$XCFLAGS"
+    OCTAVE_CC_FLAG(-mieee-fp, [
+      ieee_fp_flag=-mieee-fp
+      XTRA_CFLAGS="$XTRA_CFLAGS -mieee-fp"])
+
+    OCTAVE_CXX_FLAG(-mieee-fp, [
+      ieee_fp_flag=-mieee-fp
+      XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee-fp"])
   ;;
-  alpha-dec-osf*)
-    case "$gcc_version" in
-changequote(,)dnl
-      1.* | 2.[01234567].*)
-changequote([,])dnl
-      ;;
-      *)
-        GCC_IEEE_FP_FLAG="-mieee"
-      ;;
-    esac
+  alpha-*-*)
+    OCTAVE_CC_FLAG(-mieee, [
+      ieee_fp_flag=-mieee
+      XTRA_CFLAGS="$XTRA_CFLAGS -mieee"])
+    OCTAVE_CXX_FLAG(-mieee, [
+      ieee_fp_flag=-mieee
+      XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee"])
   ;;
 esac
-if test -n "$GCC_IEEE_FP_FLAG"; then
-  AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
-fi
-AC_SUBST(GCC_IEEE_FP_FLAG)
+
+### Octave doesn't use exceptions yet, so disable them for somewhat
+### faster and smaller code.
+
+OCTAVE_CXX_FLAG(-fno-exceptions,
+  [XTRA_CXXFLAGS="$XTRA_CXXFLAGS -fno-exceptions"])
+
+### We do our own template instantiation.
+
+OCTAVE_CXX_FLAG(-fno-implicit-templates,
+  [XTRA_CXXFLAGS="$XTRA_CXXFLAGS -fno-implicit-templates"])
+
+AC_SUBST(XTRA_CFLAGS)
+AC_SUBST(XTRA_CXXFLAGS)
 
 ### Use -static if compiling on Alpha OSF/1 1.3 systems.
 
@@ -402,8 +403,8 @@
         FFLAGS="-O"
       fi
       case "$canonical_host_type" in
-        alpha-dec-osf*)
-          if $f77_is_g77 || test -z "$GCC_IEEE_FP_FLAG"; then
+        alpha-*-*)
+          if $f77_is_g77 || test -z "$ieee_fp_flag" ; then
             true
 	  else
 	    FFLAGS="-fpe1 $FFLAGS"
@@ -857,9 +858,6 @@
 
 ### Check to see if we have IEEE math functions, and if so, which ones.
 ###
-### For Linux: add -mieee-fp flag to CFLAGS when checking for IEEE FP
-### functions, otherwise we may not find them.
-###
 ### Also check for some additional trig functions that aren't ANSI but
 ### are often available.  If they are missing, we try to replace them
 ### with functions from the BSD/NET2 math library.
@@ -877,9 +875,6 @@
   ;;
 esac
 
-XCFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $GCC_IEEE_FP_FLAG"
-
 ### I am told that Inf and NaN don't work on m68k HP sytems, and that
 ### on SCO systems, isnan and isinf don't work, but they can be
 ### replaced by something that does.
@@ -904,8 +899,6 @@
 
 AC_CHECK_FUNCS(acosh asinh atanh erf erfc gamma lgamma)
 
-CFLAGS="$XCFLAGS"
-
 ### Checks for OS specific cruft.
 
 AC_STRUCT_ST_BLKSIZE
@@ -1209,8 +1202,6 @@
 
 ### Print a summary so that important information isn't missed.
 
-CXX_EXTRAS="$HOST_CXXFLAGS $NO_IMPLICIT_TEMPLATES $GCC_IEEE_FP_FLAG"
-
 if test -z "$F77"; then
   FORT="$F2C $F2CFLAGS"
 else
@@ -1223,8 +1214,8 @@
 
   Source directory:     $srcdir
   Installation prefix:  $prefix
-  C compiler:           $CC $GCC_IEEE_FP_FLAG $CFLAGS
-  C++ compiler:         $CXX $CXX_EXTRAS $CXXFLAGS
+  C compiler:           $CC $XTRA_CFLAGS $CFLAGS
+  C++ compiler:         $CXX $XTRA_CXXFLAGS $CXXFLAGS
   Fortran compiler:     $FORT
   Fortran libraries:    $FLIBS
   Use GNU readline:     $USE_READLINE