diff configure.ac @ 15969:139f4b19a3ac

build: Improve detection of FFTW multi-threading * build-aux/common.mk: Remove FFTW3_THREADS_LIBS and FFTW3F_THREADS_LIB. * m4/acinclude.m4 (OCTAVE_CHECK_FFTW_THREADS): New macro to encapsulate checking for multi-threading support in the FFTW library. * configure.ac: Call it.
author Mike Miller <mtmiller@ieee.org>
date Mon, 21 Jan 2013 01:58:07 -0500
parents bde7731b2b83
children e27d9b9b71f4
line wrap: on
line diff
--- a/configure.ac	Fri Jan 18 16:48:12 2013 -0500
+++ b/configure.ac	Mon Jan 21 01:58:07 2013 -0500
@@ -824,12 +824,8 @@
   [])
 
 if test $build_fftw_threads = true; then
-  OCTAVE_CHECK_LIB(fftw3_threads, FFTW3_THREADS,
-    [FFTW3_THREADS library not found.  The single-threaded library is used instead.],
-    [fftw3.h], [fftw_plan_with_nthreads])
-  OCTAVE_CHECK_LIB(fftw3f_threads, FFTW3F_THREADS,
-    [FFTW3F_THREADS library not found.  The single-threaded library is used instead.],
-    [fftw3.h], [fftwf_plan_with_nthreads])
+  OCTAVE_CHECK_FFTW_THREADS(fftw3, fftw_plan_with_nthreads)
+  OCTAVE_CHECK_FFTW_THREADS(fftw3f, fftwf_plan_with_nthreads)
 fi
 
 AM_CONDITIONAL([AMCOND_HAVE_FFTW],
@@ -2907,11 +2903,9 @@
   FFTW3 CPPFLAGS:              $FFTW3_CPPFLAGS
   FFTW3 LDFLAGS:               $FFTW3_LDFLAGS
   FFTW3 libraries:             $FFTW3_LIBS
-  FFTW3_THREADS libraries:     $FFTW3_THREADS_LIBS
   FFTW3F CPPFLAGS:             $FFTW3F_CPPFLAGS
   FFTW3F LDFLAGS:              $FFTW3F_LDFLAGS
   FFTW3F libraries:            $FFTW3F_LIBS
-  FFTW3F_THREADS libraries:    $FFTW3F_THREADS_LIBS
   fontconfig CFLAGS:           $FONTCONFIG_CFLAGS
   fontconfig libraries:        $FONTCONFIG_LIBS
   FreeType2 CFLAGS:            $FT2_CFLAGS