diff configure.in @ 5505:17682e3fba2a

[project @ 2005-10-21 12:30:29 by jwe]
author jwe
date Fri, 21 Oct 2005 12:30:29 +0000
parents 3b3e8b7f0800
children b4cfbb0ec8c4
line wrap: on
line diff
--- a/configure.in	Fri Oct 21 12:25:17 2005 +0000
+++ b/configure.in	Fri Oct 21 12:30:29 2005 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.485 $)
+AC_REVISION($Revision: 1.486 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -755,21 +755,14 @@
               UMFPACK_LIBS="-lumfpack -lcblas"; with_umfpack=yes], [], $AMD_LIBS -lcblas $BLAS_LIBS)], $AMD_LIBS $BLAS_LIBS $FLIBS)], $AMD_LIBS)
 
     if test "$with_umfpack" = yes; then
-      # For now the code needed for this is not in umfpack, will add
-      # a test later that will probably have to be based on version
-      # numbers as there is no interface changes that are visible at
-      # compile time.
-      with_umfpack_split=no
-    fi
-
-    if test "$with_umfpack" = yes; then
       AC_DEFINE(HAVE_UMFPACK, 1, [Define if the UMFPACK library is used.])
       if test x"$acx_include_dir" != x; then
 	UMFPACK_INCLUDE=$acx_include_dir/umfpack.h
       fi
-      if test "$with_umfpack_split" = yes; then
-        AC_DEFINE(UMFPACK_SEPARATE_SPLIT, 1, [Define if the UMFPACK Complex solver allow matrix and RHS to be split independently])
-      fi
+      OLD_LIBS=$LIBS
+      LIBS="$LIBS $UMFPACK_LIBS $AMD_LIBS $BLAS_LIBS $FLIBS"
+      OCTAVE_UMFPACK_SEPERATE_SPLIT
+      LIBS=$OLD_LIBS
     else
       warn_umfpack="UMFPACK not found.  This will result in some lack of functionality for sparse matrices."
     fi],[