diff configure.in @ 3822:1a809dae77db

[project @ 2001-04-26 16:07:17 by jwe]
author jwe
date Thu, 26 Apr 2001 16:07:18 +0000
parents f0ab8a324da7
children 0ee55719541a
line wrap: on
line diff
--- a/configure.in	Wed Apr 25 19:01:35 2001 +0000
+++ b/configure.in	Thu Apr 26 16:07:18 2001 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.343 $)
+AC_REVISION($Revision: 1.344 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -131,25 +131,6 @@
 AC_SUBST(LIBPLPLOT)
 AC_SUBST(PLPLOT_DIR)
 
-### Allow the user disable support for command line editing using GNU
-### readline.
-
-READLINE_DIR=readline
-USE_READLINE=true
-LIBREADLINE='$(TOPDIR)/readline/libreadline.$(LIBEXT)'
-AC_ARG_ENABLE(readline,
-  [  --enable-readline       use readline library (default is yes)],
-  [if test "$enableval" = no; then
-     USE_READLINE=false;
-     LIBREADLINE="";
-     READLINE_DIR="";
-   fi], [])
-if $USE_READLINE; then
-  AC_DEFINE(USE_READLINE, 1)
-fi
-AC_SUBST(LIBREADLINE)
-AC_SUBST(READLINE_DIR)
-
 LIBKPATHSEA='$(TOPDIR)/kpathsea/libkpathsea.$(LIBEXT)'
 AC_SUBST(LIBKPATHSEA)
 
@@ -1156,17 +1137,15 @@
 
 OCTAVE_STRUCT_GR_PASSWD
 
-TERMLIBS=""
 for termlib in ncurses curses termcap terminfo termlib; do
   AC_CHECK_LIB(${termlib}, tputs, [TERMLIBS="${TERMLIBS} -l${termlib}"])
   case "${TERMLIBS}" in
     *-l${termlib}*)
-      AC_MSG_RESULT([defining TERMLIBS to be $TERMLIBS])
+      LIBS="$TERMLIBS $LIBS"
       break
     ;;
   esac
 done
-AC_SUBST(TERMLIBS)
 
 if test "$ac_cv_lib_termcap_tputs" = yes \
     || test "$ac_cv_lib_terminfo_tputs" = yes \
@@ -1179,6 +1158,8 @@
   AC_MSG_WARN($warn_termlibs)
 fi
 
+OCTAVE_ENABLE_READLINE
+
 AC_MSG_CHECKING([for struct exception in math.h])
 AC_TRY_LINK([#include <math.h>],
   [struct exception *x; x->type; x->name;],
@@ -1211,18 +1192,6 @@
 AC_CHECK_TYPE(nlink_t, short)
 OCTAVE_CHECK_TYPE(sigset_t, [#include <signal.h>], int)
 
-### Define VOID_SIGHANDLER for readline.
-
-case "$RETSIGTYPE" in
-  int)
-  ;;
-  *)
-    VOID_SIGHANDLER="-DVOID_SIGHANDLER=1"
-    AC_MSG_RESULT([defining VOID_SIGHANDLER to be 1])
-  ;;
-esac
-AC_SUBST(VOID_SIGHANDLER)
-
 ### A system dependent kluge or two.
 
 AC_CHECK_FUNCS(getrusage times)
@@ -1336,7 +1305,7 @@
 export CXX
 export F77
 
-AC_CONFIG_SUBDIRS($GLOB_DIR kpathsea scripts $PLPLOT_DIR $READLINE_DIR)
+AC_CONFIG_SUBDIRS($GLOB_DIR kpathsea scripts $PLPLOT_DIR)
 
 ### Do the substitutions in all the Makefiles.
 
@@ -1378,7 +1347,7 @@
   Fortran libraries:    $FLIBS
   BLAS libraries:       $BLAS_LIBS
   HDF5 libraries:       $HDF5_LIBS
-  Use GNU readline:     $USE_READLINE
+  LIBS:                 $LIBS
   Default pager:        $DEFAULT_PAGER
   gnuplot:              $GNUPLOT_BINARY
 
@@ -1428,6 +1397,11 @@
   warn_msg_printed=true
 fi
 
+if test -n "$warn_readline"; then
+  AC_MSG_WARN($warn_readline)
+  warn_msg_printed=true
+fi
+
 if test -n "$warn_termlibs"; then
   AC_MSG_WARN($warn_termlibs)
   warn_msg_printed=true