diff configure.ac @ 15167:1c711a646fa7

Deprecate configure variables CC_VERSION, CXX_VERSION. Replaced with GCC_VERSION, GXX_VERSION. * NEWS: Announce deprecated variables CC_VERSION, CXX_VERSION. * common.mk: Add new substitutions for GCC_VERSION, GXX_VERSION * configure.ac: Add new substitutions for GCC_VERSION, GXX_VERSION * toplev.cc (Foctave_config_info): Add variables OCTAVE_CONF_GCC_VERSION, OCTAVE_CONF_GXX_VERSION to configure info report. * oct-conf.in.h: Add variables OCTAVE_CONF_GCC_VERSION, OCTAVE_CONF_GXX_VERSION to header file.
author Rik <rik@octave.org>
date Mon, 13 Aug 2012 14:04:26 -0700
parents 8750f2cdc4f1
children 66dcad99b55e
line wrap: on
line diff
--- a/configure.ac	Mon Aug 13 12:56:53 2012 -0700
+++ b/configure.ac	Mon Aug 13 14:04:26 2012 -0700
@@ -232,7 +232,7 @@
 
 ### Check version number when using g++.
 
-CXX_VERSION=
+GXX_VERSION=
 if test "$GXX" = yes; then
   gxx_version=`$CXX -v 2>&1 | grep "^.*g.. version" | \
     sed -e 's/^.*g.. version *//' -e 's/cygnus-//' -e 's/egcs-//' -e 's/ .*//'`
@@ -242,8 +242,12 @@
       AC_MSG_ERROR([g++ version $gxx_version will probably fail to compile Octave])
     ;;
   esac
-  CXX_VERSION="$gxx_version"
+  GXX_VERSION="$gxx_version"
 fi
+AC_SUBST(GXX_VERSION)
+
+## FIXME: CXX_VERSION is deprecated and should be removed in version 3.12
+CXX_VERSION="$gxx_version"
 AC_SUBST(CXX_VERSION)
 
 ### Determine which C compiler to use (we expect to find gcc).
@@ -277,7 +281,7 @@
 
 ### Check version number when using gcc.
 
-CC_VERSION=
+GCC_VERSION=
 if test "$GCC" = yes; then
   gcc_version=`$CC -v 2>&1 | grep "^.*gcc version" | \
     sed -e 's/^.*g.. version *//' -e 's/cygnus-//' -e 's/egcs-//'`
@@ -287,10 +291,14 @@
       OCTAVE_CONFIGURE_WARNING([warn_gcc_version])
     ;;
   esac
-  CC_VERSION="$gcc_version"
+  GCC_VERSION="$gcc_version"
 fi
 AC_SUBST(CC_VERSION)
 
+## FIXME: CC_VERSION is deprecated and should be removed in version 3.12
+CC_VERSION="$gcc_version"
+AC_SUBST(GCC_VERSION)
+
 ### Determine the compiler flag necessary to create dependencies
 
 ## Assume GCC.