diff configure.in @ 2470:1e673f0648b5

[project @ 1996-11-05 21:46:06 by jwe]
author jwe
date Tue, 05 Nov 1996 21:47:59 +0000
parents 5be3f6f5986a
children 7f99808d467d
line wrap: on
line diff
--- a/configure.in	Tue Nov 05 19:40:29 1996 +0000
+++ b/configure.in	Tue Nov 05 21:47:59 1996 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.223 $)
+AC_REVISION($Revision: 1.224 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -426,11 +426,15 @@
 AC_SUBST(OCTAVE_LITE)
 
 ### special checks for odd OS specific things.
+###
+### I am told that on some SCO systems, the only place to find some
+### functions like gethostname and gettimeofday is in libsocket.
 
 AC_ISC_POSIX
 AC_MINIX
 AC_AIX
 AC_CHECK_LIB(sun, getpwnam)
+AC_CHECK_LIB(socket, gethostname)
 
 ### How big are ints and how are they oriented?  These could probably
 ### be eliminated in favor of run-time checks.
@@ -867,6 +871,8 @@
   AC_MSG_RESULT(yes)
   AC_DEFINE(HAVE_SYS_SIGLIST, 1),
   AC_MSG_RESULT(no))
+OCTAVE_SIGNAL_CHECK
+OCTAVE_REINSTALL_SIGHANDLERS
 
 ### Type stuff.