diff configure.ac @ 17330:219552139c18

Allow to compile with older freetype on RHEL5 (bug #39823). * configure.ac: Check for FT_Reference_Face in freetype. * libinterp/corefcn/txt-eng-ft.h (ft_render::ft_font::name, ft_render::ft_font::weight, ft_render::ft_font::angle, ft_render::ft_font::size, ft_render::ft_font::face): Make members private. (ft_render::ft_font::ft_font(ft_font), ft_render::ft_font::operator=): Move implementation to source file. (ft_render::ft_font::ft_font(string,string,string,double,FT_Face)): Add default value for last argument. (ft_render::ft_font::get_name, ft_render::ft_font::get_weight, ft_render::ft_font::get_angle, ft_render::ft_font::get_size, ft_render::ft_font::get_face): New methods. * libinterp/corefcn/txt-eng-ft.cc (ft_render::ft_font::ft_font(ft_font), ft_render::ft_font::operator=): Moved implementation from header file. Use FT_Reference_Face conditionally. (ft_render::ft_font::get_face): New method to lazy-load the font structure, implementation from ft_render::set_font. (ft_render::process_character, ft_render::visit(text_element_subscript), ft_render::visit(text_element_superscript), ft_render::visit(text_element_fontsize), ft_render::visit(text_element_fontname), ft_render::visit(text_element_fontstyle), ft_render::update_line_bbox, ft_render::push_new_line): Use ft_render::ft_font accessors. (ft_render::set_font): Move implementation to ft_render::ft_font::get_face. (ft_manager::do_get_font): Use font sharing conditionally, when FT_Reference_Face is present.
author Michael Goffioul <michael.goffioul@gmail.com>
date Sun, 25 Aug 2013 09:26:37 -0400
parents fb7bd09c0c0e
children bc018154e46a
line wrap: on
line diff
--- a/configure.ac	Sat Aug 24 23:29:42 2013 +0200
+++ b/configure.ac	Sun Aug 25 09:26:37 2013 -0400
@@ -1069,6 +1069,10 @@
       AC_MSG_RESULT(yes)
       AC_DEFINE(HAVE_FREETYPE, 1, [Define to 1 if you have Freetype library.])
       XTRA_CXXFLAGS="$XTRA_CXXFLAGS $FT2_CFLAGS"
+      save_LIBS="$LIBS"
+      LIBS="$FT2_LIBS $LIBS"
+      AC_CHECK_FUNCS([FT_Reference_Face])
+      LIBS="$save_LIBS"
     else
       AC_MSG_RESULT(no)
       warn_freetype="FreeType library not found.  Native graphics will be disabled."