diff configure.in @ 3065:2280158c4449

[project @ 1997-06-27 03:19:27 by jwe]
author jwe
date Fri, 27 Jun 1997 03:20:27 +0000
parents 9c6cd52f3f5a
children db6d57d718f7
line wrap: on
line diff
--- a/configure.in	Thu Jun 26 02:43:32 1997 +0000
+++ b/configure.in	Fri Jun 27 03:20:27 1997 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.280 $)
+AC_REVISION($Revision: 1.281 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -276,18 +276,21 @@
 fi
 AC_SUBST(CC_VERSION)
 
-### On Intel systems with gcc, we need to compile with -mieee-fp to
+### On Intel systems with gcc, we may need to compile with -mieee-fp to
 ### get full support for IEEE floating point.
 ###
 ### On Alpha/OSF systems, wee need -mieee, but that also
 ### requires gcc 2.8.x or later.
 
+GCC_IEEE_FP_FLAG=
 case "$canonical_host_type" in
 changequote(,)dnl
   i[3456789]86-*-*)
 changequote([,])dnl
-    GCC_IEEE_FP_FLAG="-mieee-fp"
-    AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
+    XCFLAGS="$CFLAGS"
+    CFLAGS="$CFLAGS -mieee-fp"
+    AC_TRY_LINK([], [], [GCC_IEEE_FP_FLAG="-mieee-fp"], [])
+    CFLAGS="$XCFLAGS"
   ;;
   alpha-dec-osf*)
     case "$gcc_version" in
@@ -297,11 +300,13 @@
       ;;
       *)
         GCC_IEEE_FP_FLAG="-mieee"
-        AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
       ;;
     esac
   ;;
 esac
+if test -n "$GCC_IEEE_FP_FLAG"; then
+  AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
+fi
 AC_SUBST(GCC_IEEE_FP_FLAG)
 
 ### Use -static if compiling on Alpha OSF/1 1.3 systems.