diff configure.in @ 2259:22893e3c7fbf

[project @ 1996-05-22 22:00:47 by jwe]
author jwe
date Wed, 22 May 1996 22:01:05 +0000
parents 22f40c3d0600
children d9fe34ccf2bf
line wrap: on
line diff
--- a/configure.in	Wed May 22 21:07:35 1996 +0000
+++ b/configure.in	Wed May 22 22:01:05 1996 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.205 $)
+AC_REVISION($Revision: 1.206 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -888,17 +888,21 @@
 
 ### Try to make it possible to find getrusage on Solaris systems.
 
+XCFLAGS="$CFLAGS"
 case "$canonical_host_type" in
   *-*-solaris2*)
     UCBLIB=/usr/ucblib/libucb.a
+    UCB_INCFLAGS=-I/usr/ucbinclude
     if test -f $UCBLIB; then
       LIBS="-lc $UCBLIB $LIBS"
       AC_MSG_RESULT([adding $UCBLIB to LIBS])
+      AC_MSG_RESULT([defining UCB_INCFLAGS to be $UCB_INCFLAGS])
     fi
   ;;
 esac
-
+AC_SUBST(UCB_INCFLAGS)
 AC_CHECK_FUNCS(getrusage times)
+CFLAGS="$XCFLAGS"
 
 ### Checks for other programs used for building, testing, installing,
 ### and running Octave.