diff configure.ac @ 17792:26e9312e6928

Build JIT compiler by default, but do not enable it by default. * configure.ac: Switch build_jit to "yes". * libinterp/corefcn/pt-jit.cc: Initialize Vjit_enable to false (disable at runtime). * libinterp/octave.cc: Process new --jit-compiler option. * libinterp/options-usage.h: Document new --jit-compiler option. Remove old --no-jit-compiler option.
author Rik <rik@octave.org>
date Tue, 29 Oct 2013 11:09:49 -0700
parents 4dcbbfaa4e22
children 06a850f83dd4
line wrap: on
line diff
--- a/configure.ac	Tue Oct 29 10:28:39 2013 -0700
+++ b/configure.ac	Tue Oct 29 11:09:49 2013 -0700
@@ -718,12 +718,12 @@
 
  ### Check for the LLVM library
 
-build_jit=no
+build_jit=yes
 AC_ARG_ENABLE([jit],
   [AS_HELP_STRING([--enable-jit],
     [(EXPERIMENTAL) enable JIT compiler])],
-  [if test "$enableval" = yes; then
-     build_jit=yes
+  [if test "$enableval" = no; then
+     build_jit=no
    fi],
   [])