diff configure.ac @ 11229:2f36145742c9

eliminate special cases for SCO systems
author John W. Eaton <jwe@octave.org>
date Wed, 10 Nov 2010 20:36:16 -0500
parents 29d515b9d30c
children 88e4ea8b2c19
line wrap: on
line diff
--- a/configure.ac	Wed Nov 10 16:12:52 2010 -0500
+++ b/configure.ac	Wed Nov 10 20:36:16 2010 -0500
@@ -1732,21 +1732,11 @@
 dnl fails, we try again by including math.h and invoking the function
 dnl with an argument. 
 
-### I am told that Inf and NaN don't work on m68k HP sytems, and that
-### on SCO systems, isnan and isinf don't work, but they can be
-### replaced by something that does.
+### I am told that Inf and NaN don't work on m68k HP sytems.
 
 case "$canonical_host_type" in
   m68k-hp-hpux*)
   ;;
-  *-*-sco*)
-    AC_MSG_NOTICE([defining SCO to be 1])
-    AC_DEFINE(SCO, 1, [Define if using an SCO system.])
-    AC_MSG_NOTICE([forcing HAVE_ISINF for SCO])
-    AC_DEFINE(HAVE_ISINF, 1, [Define if you have isinf().])
-    AC_MSG_NOTICE([forcing HAVE_ISNAN for SCO])
-    AC_DEFINE(HAVE_ISNAN, 1, [Define if you have isnan().])
-  ;;
   *)
     AC_CHECK_FUNCS(finite isnan isinf signbit)
     AC_CHECK_FUNCS(_finite _isnan)