diff configure.in @ 4971:3486c62f2d62

[project @ 2004-09-08 16:46:36 by jwe]
author jwe
date Wed, 08 Sep 2004 16:46:36 +0000
parents c09cbec51190
children dc5f6082aa74
line wrap: on
line diff
--- a/configure.in	Wed Sep 08 05:02:32 2004 +0000
+++ b/configure.in	Wed Sep 08 16:46:36 2004 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.455 $)
+AC_REVISION($Revision: 1.456 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1302,11 +1302,10 @@
 
 ### Someday, maybe include -ansi and even -pedantic in this list...
 
-GCC_PICKY_FLAGS="-Wcast-align -Wcast-qual -Wid-clash-31 \
- -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
- -Wstrict-prototypes -Wwrite-strings"
+GCC_PICKY_FLAGS="-Wcast-align -Wcast-qual -Wmissing-prototypes \
+  -Wpointer-arith -Wstrict-prototypes -Wwrite-strings"
 
-GXX_PICKY_FLAGS="$GCC_PICKY_FLAGS -Weffc++ -Wenum-clash -fno-nonnull-objects"
+GXX_PICKY_FLAGS="$GCC_PICKY_FLAGS -Weffc++ -Wenum-clash"
 
 AC_ARG_ENABLE(picky-flags,
   [  --enable-picky-flags    add picky options to CFLAGS, CXXFLAGS, FFLAGS],