diff configure.ac @ 17164:36fd98b9ce48

Add support for llvm 3.3 * configure.ac: Add check for LLVM IR directory. * jit-ir.cc: Update includes. * jit-util.h: Define HAVE_LLVM_DATALAYOUT. * jit-typeinfo.cc: Update includes. * pt-jit.cc: Update includes. * acinclude.m4: Update checks for llvm 3.3
author Max Brister <max@2bass.com>
date Sat, 03 Aug 2013 16:53:46 -0600
parents bb713af2e1d9
children 54e251e699bb
line wrap: on
line diff
--- a/configure.ac	Sat Aug 03 10:05:07 2013 -0700
+++ b/configure.ac	Sat Aug 03 16:53:46 2013 -0600
@@ -712,7 +712,7 @@
   AC_DEFINE(HAVE_ZLIB, 1, [Define to 1 if ZLIB is available.])
 fi
 
-### Check for the LLVM library
+ ### Check for the LLVM library
 
 build_jit=no
 AC_ARG_ENABLE([jit],
@@ -766,6 +766,7 @@
     AC_CHECK_HEADER([llvm/Support/TargetSelect.h], [
       warn_llvm=
       XTRA_CXXFLAGS="$XTRA_CXXFLAGS $LLVM_CXXFLAGS $LLVM_CPPFLAGS"])
+    OCTAVE_LLVM_IR_DIR
     OCTAVE_LLVM_IRBUILDER_HEADER
     OCTAVE_LLVM_DATALAYOUT_HEADER
     OCTAVE_LLVM_FUNCTION_ADDATTRIBUTE_API