diff configure.in @ 759:3fc1ccd5a9db

[project @ 1994-10-02 15:34:26 by jwe]
author jwe
date Sun, 02 Oct 1994 15:41:13 +0000
parents e77b62b20824
children 0e146d12d46a
line wrap: on
line diff
--- a/configure.in	Sun Oct 02 15:19:39 1994 +0000
+++ b/configure.in	Sun Oct 02 15:41:13 1994 +0000
@@ -21,7 +21,7 @@
 dnl along with Octave; see the file COPYING.  If not, write to the Free
 dnl Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
 dnl
-AC_REVISION($Revision: 1.50 $)dnl
+AC_REVISION($Revision: 1.51 $)dnl
 AC_PREREQ(1.8)dnl
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h kpathsea/c-auto.h)
@@ -172,11 +172,11 @@
 dnl
 DLD_DIR=
 LIBDLD=
-LIBOCTDLD='../liboctdld.a'
+LIBOCTDLD='liboctdld.a'
 LD_STATIC_FLAG=
 if $use_dld; then
   DLD_DIR=dld
-  LIBDLD='../libdld.a'
+  LIBDLD='../dld/libdld.a'
 # don't link them in only if doing dynamic linking and small kernel
 # requested.
   if $lite_kernel; then
@@ -233,15 +233,18 @@
 dnl Do special things for g++.
 dnl
 ADD_CXX_WALL=false
+NO_IMPLICIT_TEMPLATES=
 gxx_version=`$CXX -v 2>&1 | grep "^g.. version" | sed 's/^g.. version *//'`
 case "$gxx_version" in
-  2.5.*|2.6.*|2.7.*|2.8.*|2.9.*)
+  2.0.*|2.1.*|2.2.*|2.3.*|2.4.*)
+    AC_ERROR([g++ version $gxx_version will not work to compile Octave])
+  ;;
+  2.6.*|2.7.*|2.8.*|2.9.*)
     CXXFLAGS="-g -O"
     AC_VERBOSE([defining CXXFLAGS to be $CXXFLAGS])
-    EXTERNAL_TEMPLATES="-fexternal-templates"
-    AC_VERBOSE([defining EXTERNAL_TEMPLATES to be $EXTERNAL_TEMPLATES])
+    NO_IMPLICIT_TEMPLATES="-fno-implicit-templates"
+    AC_VERBOSE([defining NO_IMPLICIT_TEMPLATES to be $NO_IMPLICIT_TEMPLATES])
     ADD_CXX_WALL=true
-    AC_DEFINE(USE_EXTERNAL_TEMPLATES, 1)dnl
   ;;
   1.*)
     AC_WARN([g++ version $gxx_version will not work to compile Octave])
@@ -258,7 +261,7 @@
 AC_VERBOSE([defining CXXLIBS to be $CXXLIBS])
 dnl
 AC_SUBST(CXXFLAGS)dnl
-AC_SUBST(EXTERNAL_TEMPLATES)dnl
+AC_SUBST(NO_IMPLICIT_TEMPLATES)dnl
 AC_SUBST(CXXLIBS)dnl
 dnl
 dnl See which C compiler to use (we expect to find gcc).