diff configure.ac @ 13985:43cc49c7abd1

Use thread-safe atomic reference counting (GCC and MSVC). * configure.ac: New --enable-atomic-refcount argument. (octave_allocator): Fix USE_OCTAVE_ALLOCATOR variable assignment. (OCTAVE_CONFIG_INCLUDED): New macro in config.h. * oct-refcount.h (OCTREFCOUNT_ATOMIC_INCREMENT, OCTREFCOUNT_ATOMIC_INCREMENT_POST, OCTREFCOUNT_ATOMIC_DECREMENT, OCTREFCOUNT_ATOMIC_DECREMENT_POST): New macro, defined for MSVC and GCC when USE_ATOMIC_REFCOUNT is defined. (octave_refcount:operator++, octave_refcount::operator--): Use them. (octave_refcount::operator count_type): Cast returned value to volatile. (octave_refcount::direct): Remove unsafe member. * Array.h (Array::make_unique): Delete rep if refcount reaches 0. * Sparse.h (Sparse::make_unique): Delete rep if refcount reaches 0. * Array.h (Array:~Array, Array::operator=): Delete rep only when refcount is excatly 0. * Array.cc (Array::clear): Likewise. * Sparse.cc (Sparse::~Sparse, Sparse::operator=): Likewise. * SparseCmplxQR.h (SparseCmplxQR::~SparseCmplxQR, SparseCmplxQR::operator=): Likewise. * SparseQR.h (SparseQR::~SparseQR, SparseQR::operator=): Likewise. * sparse-base-chol.h (sparse_base_chol::~sparse_base_chol, sparse_base_chol::operator): Likewise. * dim-vector.h (oct-refcount.h): New included header. (dim_vector::make_unique, dim_vector::resize): Use OCTREFCOUNT_ATOMIC_DECREMENT macro and delete rep when refcount reaches 0. (dim_vector::dim_vector): Use OCTREFCOUNT_ATOMIC_INCREMENT. (dim_vector::operator=): Use OCTREFCOUNT_ATOMIC_INCREMENT and OCTREFCOUNT_ATOMIC_DECREMENT. (dim_vector::~dim_vector): Use OCTREFCOUNT_ATOMIC_DECREMENT. * oct-mutex.h (oct-refcount.h): New included header. (octave_base_mutex::count): Use octave_refcount class. * gl-render.cc (oct-refcount.h): New included header. * graphics.h.in (oct-refcount.h): Likewise. (base_property::count, base_graphics_toolkit::count, base_graphics_object::count, base_graphics_event::count): Use octave_refcount. (property::~property, property::operator=): Delete rep only when refcountn is excatly 0. * oct-map.h (octave_fields::make_unique): Delete rep when refcount reaches 0. * oct-stream.h (oct-refcount.h): New included header. (octave_base_stream::count): Use octave_refcount class. * ov.h (octave_value::make_unique): Delete rep when refcount reaches 0. * symtab.h (oct-refcount.h): New included header. (symbol_record_rep::count, fcn_info_rep::count): Use octave_refcount class. * DLD-FUNCTIONS/urlwrite.cc (oct-refcount.h): New included header. (curl_handle_rep::count): Use octave_refcount class.
author Michael Goffioul <michael.goffioul@gmail.com>
date Sat, 03 Dec 2011 15:19:42 +0000
parents a35d381e22b0
children 9867be070ee1
line wrap: on
line diff
--- a/configure.ac	Sat Dec 03 05:23:52 2011 -0500
+++ b/configure.ac	Sat Dec 03 15:19:42 2011 +0000
@@ -171,11 +171,20 @@
 AC_ARG_ENABLE(octave-allocator,
   [AS_HELP_STRING([--enable-octave-allocator],
      [use the obsolete octave_allocator class for many of Octave's objects (mostly octave_value types).  You probably do NOT want to enable this feature.  (default is no)])],
-  [if test "$enableval" = yes; then USE_ALLOCATOR=true; fi], [])
+  [if test "$enableval" = yes; then USE_OCTAVE_ALLOCATOR=true; fi], [])
 if $USE_OCTAVE_ALLOCATOR; then
   AC_DEFINE(USE_OCTAVE_ALLOCATOR, 1, [Define to use octave_allocator class.])
 fi
 
+USE_ATOMIC_REFCOUNT=false
+AC_ARG_ENABLE(atomic-refcount,
+  [AS_HELP_STRING([--enable-atomic-refcount],
+     [use atomic operations for internal reference counting. This is required for thread-safe behavior.  (default is no)])],
+  [if test "$enableval" = yes; then USE_ATOMIC_REFCOUNT=true; fi], [])
+if $USE_ATOMIC_REFCOUNT; then
+  AC_DEFINE(USE_ATOMIC_REFCOUNT, 1, [Define to use atomic operations for reference counting.])
+fi
+
 ### Make it possible to disable running Make in the doc directory.
 ### Useful for building on systems without TeX, for example.
 DOCDIR=doc
@@ -2089,6 +2098,9 @@
 typedef OCTAVE_IDX_TYPE octave_idx_type;
 
 #include <stdint.h>
+
+/* Tag indicating octave config.h has been included */
+#define OCTAVE_CONFIG_INCLUDED 1
 ])
 
 ### Do the substitutions in all the Makefiles.
@@ -2465,6 +2477,22 @@
   warn_msg_printed=true
 fi
 
+if $USE_ATOMIC_REFCOUNT; then
+  AC_MSG_WARN([])
+  AC_MSG_WARN([Using atomic reference counting.])
+  AC_MSG_WARN([This feature allows to access octave data safely from])
+  AC_MSG_WARN([another thread, for instance from a GUI. However this])
+  AC_MSG_WARN([results in a small performance penalty in the octave])
+  AC_MSG_WARN([interpreter.])
+  AC_MSG_WARN([])
+  if $USE_OCTAVE_ALLOCATOR; then
+    AC_MSG_WARN([Thread-safe behavior is not guaranteed unless you also])
+    AC_MSG_WARN([disable the use of the octave_allocator class.])
+    AC_MSG_WARN([])
+  fi
+  warn_msg_printed=true
+fi
+
 if $warn_msg_printed; then
   AC_MSG_NOTICE([])
   AC_MSG_NOTICE([NOTE: libraries may be skipped if a library is not found OR])